AnalysisObjectEnumerator Class |
The AnalysisObjectEnumerator class provides the means to iterate through analysis object instances.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisObjectEnumerator type exposes the following members.
Properties
Name | Description | |
---|---|---|
Current | Gets the current analysis object in the enumerator. | |
CurrentItem | Gets or sets the index of the current item. | |
CurrentSelected | Gets or sets the currently selected item. | |
SelectInstances |
Gets or sets a value indicating whether the instance's Select() is called when the "Current" item is asked from the enumerator.
The user can set this to "false" if no members are ever asked from the instance. This is the case
when e.g. asking only a report property from this identifier. WARNING: normally the user should not change this value.
|
Methods
Name | Description | |
---|---|---|
GetEnumerator |
Returns a pointer to the existing instance of the class.
This allows the usage of the foreach statement with AnalysisObjectEnumerator.
| |
GetSize | Returns the total amout of items. | |
MoveNext |
Moves to the next item in the enumerator.
| |
Refresh | Refreshes the enumerator with latest data at database. | |
Reset | Resets the enumerator to the beginning. |
See Also