AnalysisObject Class

The AnalysisObject class is an abstract base class for all analysis objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObject
    More...

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public abstract class AnalysisObject

The AnalysisObject type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisObject
Initializes a new instance of the AnalysisObject class.
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
Public propertyFatherObject2Type
Gets or sets the type of the father object.
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
Public propertyFatherObjectType
Gets or sets the type of the father object.
Public propertyID
Gets or sets the identifier of the analysis object.
Top
Methods
  NameDescription
Public methodSelect
Selects an analysis object from the database.
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObject
    Tekla.Structures.AnalysisAnalysisArea
    Tekla.Structures.AnalysisAnalysisAreaPolygon
    Tekla.Structures.AnalysisAnalysisBar
    Tekla.Structures.AnalysisAnalysisCrossSection
    Tekla.Structures.AnalysisAnalysisDecomposedLoad
    Tekla.Structures.AnalysisAnalysisDesignParameterBase
    Tekla.Structures.AnalysisAnalysisEdge
    Tekla.Structures.AnalysisAnalysisFace
    Tekla.Structures.AnalysisAnalysisLoadCombination
    Tekla.Structures.AnalysisAnalysisLoadGroup
    Tekla.Structures.AnalysisAnalysisMaterial
    Tekla.Structures.AnalysisAnalysisMember
    Tekla.Structures.AnalysisAnalysisModel
    Tekla.Structures.AnalysisAnalysisModelConnectivityRule
    Tekla.Structures.AnalysisAnalysisModelLoad
    Tekla.Structures.AnalysisAnalysisNode
    Tekla.Structures.AnalysisAnalysisNodeLink
    Tekla.Structures.AnalysisAnalysisPart
    Tekla.Structures.AnalysisAnalysisPosition
    Tekla.Structures.AnalysisAnalysisRigidDiaphragm
    Tekla.Structures.AnalysisAnalysisSubSection
    Tekla.Structures.AnalysisAnalysisVolume
    Tekla.Structures.AnalysisAnalysisVolumeItem
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next