AnalysisModelSpectrumProperties Class |
The AnalysisModelSpectrumProperties class contains information related to analysis model spectrum properties.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisModelSpectrumProperties type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisModelSpectrumProperties | Initializes a new instance of the AnalysisModelSpectrumProperties class |
Properties
Name | Description | |
---|---|---|
SpectrumAcceleration |
The list of the accelerations of the spectrum.
| |
SpectrumASCEf1 |
The ASCEf1 value of the spectrum.
| |
SpectrumASCEf2 |
The ASCEf2 value of the spectrum.
| |
SpectrumCombination |
The spectrum combination.
| |
SpectrumCompositeDampingRatioX |
The list of the composite damping rations in the X direction of the spectrum.
| |
SpectrumCompositeDampingRatioY |
The list of the composite damping rations in the Y direction of the spectrum.
| |
SpectrumCompositeDampingRatioZ |
The list of the composite damping rations in the Z direction of the spectrum.
| |
SpectrumDampingFactor |
The damping factor of the spectrum.
| |
SpectrumDampingPointID |
The list of the damping point identifiers of the spectrum.
| |
SpectrumDampingType |
The type of the spectrum damping.
| |
SpectrumInterpolation |
The interpolation of the spectrum.
| |
SpectrumMaximumDampingRatio |
The maximum damping ratio of the spectrum.
| |
SpectrumMinimumDampingRatio |
The minimum damping ratio of the spectrum.
| |
SpectrumMissingMass |
The missing mass of the spectrum.
| |
SpectrumMissingMassEnable |
Indicates whether the missing mass of the spectrum is enabled.
| |
SpectrumModalDampingRatio |
The list of the modal damping ratios of the spectrum.
| |
SpectrumModalDampingRatioEnable |
Indicates whether the damping ratio of the spectrum is enabled.
| |
SpectrumModeCount |
The count of the spectrum mode.
| |
SpectrumPeriod |
The list of the periods of the spectrum.
| |
SpectrumScale |
The scale of the spectrum.
| |
SpectrumType |
The type of the spectrum.
| |
SpectrumXdirection |
The X direction of the spectrum.
| |
SpectrumXdirectionEnable |
Indicates whether the X direction of the spectrum is enabled.
| |
SpectrumYdirection |
The Y direction of the spectrum.
| |
SpectrumYdirectionEnable |
Indicates whether the Y direction of the spectrum is enabled.
| |
SpectrumZdirection |
The Z direction of the spectrum.
| |
SpectrumZdirectionEnable |
Indicates whether the Z direction of the spectrum is enabled.
|
See Also