AnalysisModelConnectivityRule Class |
The AnalysisModelConnectivityRule class contains information related to analysis model connectivity rules.
Inheritance Hierarchy
SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisModelConnectivityRule
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisModelConnectivityRule
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisModelConnectivityRule type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisModelConnectivityRule | Initializes a new instance of the AnalysisModelConnectivityRule class |
Properties
Name | Description | |
---|---|---|
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
Group1 |
The group name 1 of the connectivity rule.
| |
Group2 |
The group name 2 of the connectivity rule.
| |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
Linkage1 |
The linkage 1 of the connectivity rule.
| |
Linkage2 |
The linkage 2 of the connectivity rule.
| |
MagneticDistance |
The magnetic distance of the connectivity rule.
| |
Status |
The status of the connectivity rule.
|
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis connectivity rule.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |
See Also