AnalysisMember Class

The AnalysisMember class contains information related to analysis members.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class AnalysisMember : AnalysisObject

The AnalysisMember type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisMember
Initializes a new instance of the AnalysisMember class.
Top
Properties
  NameDescription
Public propertyAnalysisDesignCode
Gets or sets the analysis design code of the member.
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyComposite
Gets or sets the composite settings of the member.
Public propertyCurvature
Gets or sets the beam curvature of the member.
Public propertyEnd
Gets or sets the analysis beam end settings at the end of the member.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyLabel
Gets or sets the label of the analysis member.
Public propertyMaterial
Gets or sets the material of the analysis member.
Public propertyStart
Gets or sets the analysis beam end settings at the start of the member.
Top
Methods
  NameDescription
Public methodCopyData
Copies data from another analysis member.
Public methodModify
Modifies an analysis member. The AnalysisModelName has to be set.
Public methodSelect
Selects an analysis member. The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next