AnalysisLoadGroup Class

The AnalysisLoadGroup class contains information related to analysis load groups.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class AnalysisLoadGroup : AnalysisObject

The AnalysisLoadGroup type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisLoadGroup
Initializes a new instance of the AnalysisLoadGroup class.
Top
Properties
  NameDescription
Public propertyCompatible
Gets or sets a value indicating whether the load group is compatible.
Public propertyCompatibleNumber
Gets or sets the load group compatible number.
Public propertyDirection
Gets or sets the direction of the load group.
Public propertyIncompatible
Gets or sets a value indicating whether the load group is incompatible.
Public propertyIncompatibleNumber
Gets or sets the load group incompatible number.
Public propertyLoadGroupID
Gets or sets the identifier of the load group.
Public propertyName
Gets or sets the name of the load group.
Public propertyType
Gets or sets the type of the load group.
Top
Methods
  NameDescription
Public methodStatic memberGetTypeName
Get load group type name, translated to current language.
Public methodIsEmpty
Check if load group is empty (no loading exists).
Public methodIsSelfWeight
Check if load group is self weight load group.
Public methodSelect
Selects an AnalysisLoadGroup. The ID has to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next