AnalysisDesignParameterBase Class

The AnalysisDesignParameterBase class contains base information related to analysis design parameters.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public abstract class AnalysisDesignParameterBase : AnalysisObject

The AnalysisDesignParameterBase type exposes the following members.

Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyIsGeneral
Gets or sets a value indicating whether the design parameter is general.
Public propertyName
Gets or sets the name of the analysis design parameter.
Public propertyUnit
Gets or sets the unit of the analysis design parameter.
Top
Methods
  NameDescription
Public methodModify
Modifies an analysis design parameter at the database. Inserts if parameter does not exist.
Public methodSelect
Selects an analysis object from the database.
(Inherited from AnalysisObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next