AnalysisDecomposedSelfweightLoad Class |
The AnalysisDecomposedSelfweightLoad class contains information of decomposed selfweight loads.
Inheritance Hierarchy
SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedSelfweightLoad
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedSelfweightLoad
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisDecomposedSelfweightLoad type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisDecomposedSelfweightLoad | Initializes a new instance of the AnalysisDecomposedSelfweightLoad class |
Properties
Name | Description | |
---|---|---|
Directions |
The directions of the decomposed selfweight load.
| |
Factors |
The factors of the decomposed selfweight load.
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis decomposed selfweight load.
(Overrides AnalysisObjectSelect.) |
See Also