AnalysisDecomposedSelfweightLoad Class |
The AnalysisDecomposedSelfweightLoad class contains information of decomposed selfweight loads.
Inheritance Hierarchy
SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedSelfweightLoad
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedSelfweightLoad
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisDecomposedSelfweightLoad type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisDecomposedSelfweightLoad | Initializes a new instance of the AnalysisDecomposedSelfweightLoad class |
Properties
Name | Description | |
---|---|---|
AnalysisLoadType |
Gets or sets the type of the analysis decomposed load.
(Inherited from AnalysisDecomposedLoad.) | |
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
Directions |
The directions of the decomposed selfweight load.
| |
Factors |
The factors of the decomposed selfweight load.
| |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
ModelLoadGroupID |
Gets or sets the identifier of the load group.
(Inherited from AnalysisDecomposedLoad.) | |
ModelLoadID |
Gets or sets the identifier of the model load.
(Inherited from AnalysisDecomposedLoad.) | |
ObjectAttachedToID |
Gets or sets the identifier of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.) | |
ObjectAttachedToType |
Gets or sets the type of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.) |
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis decomposed selfweight load.
(Overrides AnalysisObjectSelect.) |
See Also