AnalysisDecomposedLoad Class |
The AnalysisDecomposedLoad class contains information related to decomposed loads.
Inheritance Hierarchy
SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
More...
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
More...
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisDecomposedLoad type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisDecomposedLoad |
Initializes a new instance of the AnalysisDecomposedLoad class.
|
Properties
Name | Description | |
---|---|---|
AnalysisLoadType |
Gets or sets the type of the analysis decomposed load.
| |
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
ModelLoadGroupID |
Gets or sets the identifier of the load group.
| |
ModelLoadID |
Gets or sets the identifier of the model load.
| |
ObjectAttachedToID |
Gets or sets the identifier of the object the load is attached to.
| |
ObjectAttachedToType |
Gets or sets the type of the object the load is attached to.
|
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis object from the database.
(Inherited from AnalysisObject.) |
See Also
Reference
Inheritance Hierarchy
SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedAreaLoad
Tekla.Structures.AnalysisAnalysisDecomposedBarLoad
Tekla.Structures.AnalysisAnalysisDecomposedMemberLoad
Tekla.Structures.AnalysisAnalysisDecomposedNodeLoad
Tekla.Structures.AnalysisAnalysisDecomposedSelfweightLoad
Tekla.Structures.AnalysisAnalysisDecomposedTemperatureLoad
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedAreaLoad
Tekla.Structures.AnalysisAnalysisDecomposedBarLoad
Tekla.Structures.AnalysisAnalysisDecomposedMemberLoad
Tekla.Structures.AnalysisAnalysisDecomposedNodeLoad
Tekla.Structures.AnalysisAnalysisDecomposedSelfweightLoad
Tekla.Structures.AnalysisAnalysisDecomposedTemperatureLoad