AnalysisDecomposedLoadAnalysisLoadTypeEnum Enumeration |
Defines the analysis load types.
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
NOT_DEFINED | 0 | The analysis load type is not defined. | |
ANALYSIS_NODAL_LOAD | 1001 | The analysis nodal load. | |
ANALYSIS_MEMBER_LINE_LOADX | 1 | The analysis member line load in the X direction. | |
ANALYSIS_MEMBER_LINE_LOADY | 2 | The analysis member line load in the Y direction. | |
ANALYSIS_MEMBER_LINE_LOADZ | 3 | The analysis member line load in the Z direction. | |
ANALYSIS_MEMBER_LINE_MOMENTX | 4 | The analysis member line moment load in the X direction. | |
ANALYSIS_MEMBER_LINE_MOMENTY | 5 | The analysis member line moment load in the Y direction. | |
ANALYSIS_MEMBER_LINE_MOMENTZ | 6 | The analysis member line moment load in the Z direction. | |
ANALYSIS_MEMBER_POINT_LOADX | 7 | The analysis member point load in the X direction. | |
ANALYSIS_MEMBER_POINT_LOADY | 8 | The analysis member point load in the Y direction. | |
ANALYSIS_MEMBER_POINT_LOADZ | 9 | The analysis member point load in the Z direction. | |
ANALYSIS_MEMBER_POINT_MOMENTX | 10 | The analysis member point moment load in the X direction. | |
ANALYSIS_MEMBER_POINT_MOMENTY | 11 | The analysis member point moment load in the Y direction. | |
ANALYSIS_MEMBER_POINT_MOMENTZ | 12 | The analysis member point moment load in the Z direction. | |
ANALYSIS_MEMBER_TEMPERATURE_LOAD | 13 | The analysis member temperature load. | |
ANALYSIS_PLATE_POINT_LOAD | 14 | The analysis area point load. | |
ANALYSIS_PLATE_LINE_LOAD | 15 | The analysis area line load. | |
ANALYSIS_PLATE_PRESSURE_LOAD | 16 | The analysis area pressure load. | |
ANALYSIS_BAR_LINE_LOADX | 21 | The analysis bar line load in the X direction. | |
ANALYSIS_BAR_LINE_LOADY | 22 | The analysis bar line load in the Y direction. | |
ANALYSIS_BAR_LINE_LOADZ | 23 | The analysis bar line load in the Z direction. | |
ANALYSIS_BAR_LINE_MOMENTX | 24 | The analysis bar line moment load in the X direction. | |
ANALYSIS_BAR_LINE_MOMENTY | 25 | The analysis bar line moment load in the Y direction. | |
ANALYSIS_BAR_LINE_MOMENTZ | 26 | The analysis bar line moment load in the Z direction. | |
ANALYSIS_BAR_POINT_LOADX | 27 | The analysis bar point load in the X direction. | |
ANALYSIS_BAR_POINT_LOADY | 28 | The analysis bar point load in the Y direction. | |
ANALYSIS_BAR_POINT_LOADZ | 29 | The analysis bar point load in the Z direction. | |
ANALYSIS_BAR_POINT_MOMENTX | 30 | The analysis bar point moment load in the X direction. | |
ANALYSIS_BAR_POINT_MOMENTY | 31 | The analysis bar point moment load in the Y direction. | |
ANALYSIS_BAR_POINT_MOMENTZ | 32 | The analysis bar point moment load in the Z direction. | |
ANALYSIS_BAR_TEMPERATURE_LOAD | 33 | The analysis bar temperature load. |
See Also