AnalysisCompositeBeam Class

The AnalysisCompositeBeam class contains information related to analysis composite beams.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisCompositeBeam

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class AnalysisCompositeBeam

The AnalysisCompositeBeam type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisCompositeBeam
Initializes a new instance of the AnalysisCompositeBeam class
Top
Properties
  NameDescription
Public propertyComposite
Indicates whether the beam is composite.
Public propertyConcreteStrength
The strength of the concrete of the analysis composite beam.
Public propertyRibDirection
The direction of the rib of the analysis composite beam (in the global coordinate system).
Public propertyRibHeight
The height of the rib of the analysis composite beam.
Public propertyRibWidth
The width of the rib of the analysis composite beam.
Public propertySlabMaterial
The slab material of the analysis composite beam.
Public propertySlabThickness
The thickness of the slab of the analysis composite beam.
Public propertySlabWidthLeft
The left width of the slab of the analysis composite beam.
Public propertySlabWidthRight
The right width of the slab of the analysis composite beam.
Public propertyStudDiameter
The diameter of the stud of the analysis composite beam.
Public propertyStudLength
The length of the stud of the analysis composite beam.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next