![]() | AnalysisBar Class |
The AnalysisBar class contains information related to analysis bars.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The AnalysisBar type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisBar |
Initializes a new instance of the AnalysisBar class.
|

Name | Description | |
---|---|---|
![]() | AnalysisDesignCode |
Gets or sets the analysis design code of the analysis bar.
|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | AnalysisType |
Gets or sets the analysis type of the analysis bar.
|
![]() | CardinalPoint |
Gets or sets the cardinal point of the analysis bar.
|
![]() | Composite |
Gets or sets the composite beam of the analysis bar.
|
![]() | Curvature |
Gets or sets the curvature of the analysis bar.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Label |
Gets or sets the label of the analysis bar.
|
![]() | Material |
Gets or sets the material of the analysis bar.
|
![]() | Members |
Gets the members of the analysis bar.
|
![]() | Positions |
Gets the positions of the analysis bar.
|
![]() | ProfileEnd |
Gets or sets the end profile of the analysis bar.
|
![]() | ProfileStart |
Gets or sets the start profile of the analysis bar.
|

Name | Description | |
---|---|---|
![]() | Add(AnalysisPosition) |
Adds a position to the analysis bar.
|
![]() | Add(AnalysisPosition, AnalysisMember) |
Adds a position and member to the analysis bar.
|
![]() | Delete |
Deletes an analysis bar.
The method is not implemented.
|
![]() | GetMembers |
Gets the members of the analysis bar.
|
![]() | GetPositions |
Gets the positions of the analysis bar.
|
![]() | Modify |
Modifies an analysis bar.
The method is not implemented.
|
![]() | Select |
Selects an analysis bar.
The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.) |