AnalysisAreaPolygon Class |
The AnalysisAreaPolygon class contains information related to analysis area polygons.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The AnalysisAreaPolygon type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisAreaPolygon |
Creates a new instance of the AnalysisAreaPolygon class.
|
Properties
Name | Description | |
---|---|---|
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
Edges |
The edges of the area polygon.
| |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
Positions |
The positions of the area polygon.
|
Methods
Name | Description | |
---|---|---|
Add |
Adds a position to the analysis area polygon.
Also adds an edge.
| |
GetEdges |
Gets the edges of the area polygon.
| |
GetPositions |
Gets the positions of the area polygon.
| |
Insert |
Inserts an analysis area polygon.
The AnalysisModelName has to be set.
| |
Select |
Selects an analysis area polygon.
The AnalysisObjectType has to be set.
(Overrides AnalysisObjectSelect.) |
See Also