![]() | TaskAddObjectsToTask Method |
Adds objects to the task.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Parameters
- ModelObjects
- Type: System.CollectionsArrayList
An array list of model objects to be added to the task.
Return Value
Type: BooleanTrue on success.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
using Tekla.Structures.Model; using System.Collections; public class Example { public void Example1() { // Add beam1 and beam2 into the task. Task task = new Task(); Beam beam1 = new Beam(); Beam beam2 = new Beam(); if (task.Insert() && beam1.Insert() && beam2.Insert()) { ArrayList objectsToAdd = new ArrayList(); objectsToAdd.Add(beam1); objectsToAdd.Add(beam2); task.AddObjectsToTask(objectsToAdd); } } }
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)