WpfSaveLoad Class |
Interaction logic for WpfSaveload.xaml
WpfSaveLoad
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfSaveLoad
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfSaveLoad
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The WpfSaveLoad type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WpfSaveLoad |
Initializes a new instance of the WpfSaveLoad class with the default language and file extensions.
|
Properties
Name | Description | |
---|---|---|
HelpFileType |
Gets or sets the help file type.
| |
HelpKeyword |
Gets or sets the HelpKeyword that the help file should be opened for.
If you do not provide a HelpKeyword and HelpUrl is not set, the default
start page for Tekla Structures Help viewer is displayed.
| |
HelpUrl |
Gets or sets the HelpUrl where the help file is located.
If you do not provide a HelpUrl, the Tekla Structures help viewer will be displayed with given HelpKeyword.
| |
SaveAsText |
Gets or sets the text in the SaveAs text box.
| |
SaveLoadText |
Gets the currently selected file name in the Save/Load combo box.
| |
SelectedFileName |
Gets or sets the text in the SaveAs text box.
| |
UserDefinedHelpFilePath |
Gets or sets the file path where the UserDefined help file is located.
If you do not provide a UserDefinedHelpFilePath, the general Help file, help.chm, will be displayed.
|
Methods
Name | Description | |
---|---|---|
InitializeComponent |
InitializeComponent
|
Events
Name | Description | |
---|---|---|
AttributesLoadClicked |
The AttributesLoadClicked event is triggered just after the load button has been clicked.
| |
AttributesLoaded |
The AttributesLoaded event is triggered just after attributes have been loaded into the dialog.
| |
AttributesSaveClicked |
The AttributesSaveClicked event is triggered just after the save button has been clicked.
| |
AttributesSaved |
The AttributesSaved event is triggered just after attributes are saved to a file.
| |
HelpOpenClicked |
The HelpOpenClicked event is triggered just after the help button has been clicked.
| |
HelpOpened |
The HelpOpened event is triggered just after the help file is opened.
|
See Also