WpfProfileCatalog Class

The WpfProfileCatalog class represents a group of controls to select profiles using the profile catalog.
WpfProfileCatalog
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class WpfProfileCatalog : UserControl, 
	IComponentConnector

The WpfProfileCatalog type exposes the following members.

Constructors
  NameDescription
Public methodWpfProfileCatalog
Initiates a new instance of the control.
Public methodWpfProfileCatalog(String)
Initiates a new instance of the control selecting the given profile.
Top
Properties
  NameDescription
Public propertyButtonHeight
Gets and sets the height of the button control.
Public propertyButtonText
Gets and sets the text of the button control.
Public propertyButtonWidth
Gets and sets the width of the button control.
Public propertySelectedProfile
The selected profile in the control.
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next