WpfMeshCatalog Class |
The WpfMeshCatalog class represents a group of controls to select meshes
using the mesh catalog.
WpfMeshCatalog
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfMeshCatalog
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfMeshCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The WpfMeshCatalog type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WpfMeshCatalog |
Initiates a new instance of the control.
|
Properties
Name | Description | |
---|---|---|
ButtonHeight |
Gets and sets the height of the button control.
| |
ButtonText |
Gets and sets the text of the button control.
| |
ButtonWidth |
Gets and sets the width of the button control.
| |
SelectedMeshGrade |
The mesh grade in the control.
| |
SelectedMeshName |
The mesh name in the control.
|
Methods
Name | Description | |
---|---|---|
InitializeComponent |
InitializeComponent
|
Events
Name | Description | |
---|---|---|
SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
| |
SelectionDone |
The SelectionDone event is raised when the selection has been done.
|
See Also