WindowBase Class |
The WindowBase class is the base class for all Tekla Structures WPF dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Tekla.Structures.DialogWindowBase
Tekla.Structures.DialogApplicationWindowBase
Tekla.Structures.DialogPluginWindowBase
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Tekla.Structures.DialogWindowBase
Tekla.Structures.DialogApplicationWindowBase
Tekla.Structures.DialogPluginWindowBase
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The WindowBase type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WindowBase |
The default constructor that does not need parameters.
Initializes the window and registers property bindings.
|
Properties
Name | Description | |
---|---|---|
Localization |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
| |
LocExtension |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
| |
UseDefaultStyle |
Use default style in all the window controls or not.
If the property is not set in the window constructor the default value (true) is used.
|
Methods
Name | Description | |
---|---|---|
ApplyValues |
Loads the dialog values from a file and performs Apply on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
| |
GetConnectionStatus |
Returns true if a proper connection to the Tekla Structures process has been established.
Currently, there's no way to re-establish the connection.
| |
GetUnitDecimals |
Gets the number of decimals Tekla Structures uses with the specified unit type.
| |
InitializeAngleUnitDecimals |
Gets the number of decimals Tekla Structures uses for displaying the angle unit and
initializes Angle class to use that.
| |
InitializeDistanceUnitDecimals |
Gets the number of decimals Tekla Structures uses for displaying the "length" unit and
initializes the distance datatype to use that.
| |
InitializeUnitDecimals |
Gets the number of decimals Tekla Structures uses for displaying its units and
initializes the Tekla.Structures.Datatype classes to use them.
| |
InitializeWindow |
Prepares the data storage for the dialog and scans through the fields.
| |
LoadValues |
Loads the dialog values from a file. To match the files to a certain dialog,
the file suffix is set as the dialog type's name.
| |
ModifyValues |
Loads the dialog values from a file and performs Modify on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
| |
SaveValues |
Serializes the dialog values to an xml file.
| |
ShowWindow |
Displays the window.
| |
UpdateDataStorageFromViewModel |
DO NOT USE! For internal usage only!
|
See Also