WeldWeldAttributes Class |
The WeldAttributes class is the attributes class for the weld.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The WeldWeldAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WeldWeldAttributes |
Creates a new default weld attributes instance that loads standard attributes.
| |
WeldWeldAttributes(String) |
Creates a new weld attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
CustomPresentation |
Custom presentation GUID to be applied to the weld
| |
DrawHiddenLines |
True if hidden lines are drawn.
| |
DrawOwnHiddenLines |
True if own hidden lines are drawn.
| |
HiddenLines |
The line type of hidden lines.
| |
Representation |
The representation of the weld.
| |
VisibleLines |
The line type of visible lines.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also