WeldMark Class

The WeldMark class defines a drawing object that illustrates a weld mark in a specific view. WeldMark class refers to welding marks that appear when creating/updating drawing views. In this case, ModelIdentifier has a value. WeldMark class also refers to weld marks created with drawing editor UI. In this case, ModelIdentifier value is zero. Graphical representation of welding marks (line and text properties) can be modified using .wel setting files. The welding mark settting files (.wls) cannot be used to modify instances of WeldMark class.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class WeldMark : DrawingObject, 
	IObjectAlignedBoundingBox, IAxisAlignedBoundingBox, IMovableRelative, IHideable, IHasChildren

The WeldMark type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyInsertionPoint
The insertion point of the mark.
Public propertyModelIdentifier
When instance refers to welding mark related to a weld in model database, ModelIdentifier has a value. When instance refers to weld mark created with drawing editor UI, value is zero.
Top
Methods
  NameDescription
Public methodDelete
Deletes the weld mark from the current drawing database.
(Overrides DatabaseObjectDelete.)
Public methodGetAxisAlignedBoundingBox
Returns the axis aligned bounding box of the weld mark (rectangle format).
Public methodGetObjectAlignedBoundingBox
Returns the object aligned bounding box of the weld mark (rectangle format).
Public methodGetObjects
Gets the children objects of the current object.
Public methodGetObjects(Type)
Gets the children objects of the current object that are of certain types.
Public methodInsert
NOT YET IMPLEMENTED. Welding marks connected with welds in the model database appear when drawing views are created/updated. Weld marks created with drawing editor UI cannot be inserted with API code.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the weld mark in the current drawing database. Attributes can be modified with .wel setting files.
(Overrides DatabaseObjectModify.)
Public methodMoveObjectRelative
Moves the object using the move vector.
Public methodSelect
Selects the weld mark from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
Examples
The following code modifies a weld mark in the current drawing:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class WeldMarkExample
{
    public void WeldMarkModify()
    {
        DrawingHandler myDrawingHandler = new DrawingHandler();
        DrawingObjectSelector dos = myDrawingHandler.GetDrawingObjectSelector();
        DrawingObjectEnumerator allObjectsOnSheet = dos.GetSelected();
        while (allObjectsOnSheet.MoveNext())
        {
            if (allObjectsOnSheet.Current is Tekla.Structures.Drawing.WeldMark)
            {
                WeldMark weldMark = allObjectsOnSheet.Current as Tekla.Structures.Drawing.WeldMark;
                weldMark.Modify();
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next