ViewVisibilitySettings Class |
The View visibility settings class contains object visibility information related to view.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model.UI
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The ViewVisibilitySettings type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ViewVisibilitySettings | Initializes a new instance of the ViewVisibilitySettings class |
Properties
Name | Description | |
---|---|---|
BoltHolesVisible |
Gets or sets the bolt hole visibility.
| |
BoltHolesVisibleInComponents |
Gets or sets the bolt hole visibility inside components.
| |
BoltsVisible |
Gets or sets the bolt visibility.
| |
BoltsVisibleInComponents |
Gets or sets the bolt visibility inside components.
| |
BuildingSpaceVisible |
Gets or sets the building space visibility.
| |
BuildingVisible |
Gets or sets the building heirarchy visibility.
| |
ComponentsVisible |
Gets or sets the component symbol visibility.
| |
ComponentsVisibleInComponents |
Gets or sets the component symbol visibility inside components.
| |
ConstructionLinesVisible |
Gets or sets the construction line visibility.
| |
ConstructionPlanesVisible |
Gets or sets the construction plane visibility.
| |
ConstructionPlanesVisibleInComponents |
Gets or sets the construction plane visibility inside components.
| |
CutsVisible |
Gets or sets the cut or union visibility.
| |
CutsVisibleInComponents |
Gets or sets the cut visibility inside components.
| |
FittingsVisible |
Gets or sets the fitting visibility.
| |
FittingsVisibleInComponents |
Gets or sets the fitting visibility inside components.
| |
GridsVisible |
Gets or sets the grid visibility.
| |
LoadsVisible |
Gets or sets the load visibility.
| |
PartsVisible |
Gets or sets the part visibility.
| |
PartsVisibleInComponents |
Gets or sets the part visibility inside components.
| |
PointsVisible |
Gets or sets the point visibility.
| |
PointsVisibleInComponents |
Gets or sets the point visibility inside components.
| |
PourBreaksVisible |
Gets or sets the pour break visibility.
NOTE! this setting requires that XS_ENABLE_POUR_MANAGEMENT is set to true.
| |
PoursVisible |
Gets or sets the pour visibility.
NOTE! this setting requires that XS_ENABLE_POUR_MANAGEMENT is set to true.
| |
RebarsVisible |
Gets or sets the reinforcement visibility.
| |
RebarsVisibleInComponents |
Gets or sets the reinforcement visibility inside components.
| |
ReferenceObjectsVisible |
Gets or sets the reference object visibility.
| |
SurfaceTreatmentsVisible |
Gets or sets the surface treatment visibility.
| |
WeldsVisible |
Gets or sets the weld visibility.
| |
WeldsVisibleInComponents |
Gets or sets the weld visibility inside components.
|
See Also