ViewViewShorteningAttributes Class |
The ViewShorteningAttributes class sets the shortening attributes for the view.
If CutParts is set to true, the other values are applied. If it is false, none of the other values matter.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewViewShorteningAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewViewShorteningAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ViewViewShorteningAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ViewViewShorteningAttributes |
Creates a new default view shortening attributes instance.
| |
ViewViewShorteningAttributes(Boolean, Boolean, Double, Double, ViewShorteningCutPartType) |
Creates a new view shortening attributes instance with the given parameters.
|
Properties
Name | Description | |
---|---|---|
CutParts |
Defines whether cut parts are enabled (true) or disabled (false).
| |
CutPartType |
Defines cut part type. Not used if CutParts is false.
| |
CutSkewParts |
Defines whether cut skewed parts are enabled (true) or disabled (false).
| |
MinimumLength |
The minimum cut part length.
| |
Offset |
The space between the cut parts.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also