ViewHandler Class |
The ViewHandler class contains methods for handling views.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model.UI
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The ViewHandler type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ViewHandler | Initializes a new instance of the ViewHandler class |
Methods
Name | Description | |
---|---|---|
GetAllViews | Fetches all the views from the model. | |
GetPermanentViews | Returns the permanent views. | |
GetSelectedViews | Returns the views the user has selected. | |
GetTemporaryViews | Returns the temporary views. | |
GetVisibleViews | Returns the visible views. | |
HideView | Closes a model view. | |
RedrawView | Redraws a model view. | |
RedrawWorkplane | Sets the workplane to current transformation plane and redraws it. | |
SetRepresentation | Sets the object representation. | |
ShowView | Opens a model view. | |
ZoomToBoundingBox(AABB) | Zooms the current model view. | |
ZoomToBoundingBox(View, AABB) | Zooms a model view. |
Examples
using Tekla.Structures.Model.UI; public class Example { public void Example1() { ViewHandler.SetRepresentation("standard"); ModelViewEnumerator ViewEnum = ViewHandler.GetAllViews(); while (ViewEnum.MoveNext()) { View ViewSel = ViewEnum.Current; ViewHandler.ShowView(ViewSel); ViewHandler.RedrawView(ViewSel); ViewHandler.HideView(ViewSel); } } }
See Also