View Constructor (ContainerView, CoordinateSystem, CoordinateSystem, ArrayList, String) |
Creates a new view instance with the given coordinate systems, part list and attributes file's filename.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public View( ContainerView View, CoordinateSystem ViewCoordinateSystem, CoordinateSystem DisplayCoordinateSystem, ArrayList PartList, string Attributes )
Parameters
- View
- Type: Tekla.Structures.DrawingContainerView
The container view where the view is placed. - ViewCoordinateSystem
- Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system of the view restriction box. - DisplayCoordinateSystem
- Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system of the display plane. - PartList
- Type: System.CollectionsArrayList
An array list of identifiers of model objects to be shown in the view. For reference models both reference model and reference model object are required. - Attributes
- Type: SystemString
The name of the attributes file to be used.
See Also