ViewBase Class |
The ViewBase class is a base class for both the ContainerView class and the View class.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingViewBase
Tekla.Structures.DrawingContainerView
Tekla.Structures.DrawingView
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingViewBase
Tekla.Structures.DrawingContainerView
Tekla.Structures.DrawingView
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ViewBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes of the current object.
Only attributes of the same type as the object are allowed.
(Inherited from DrawingObject.) | |
ExtremaCenter |
Gets the view extrema center.
| |
FrameOrigin |
The vector from the view origin to the frame origin.
| |
Height |
The height of the view frame in paper coordinates.
| |
IsSheet |
Gets a value indicating whether the container view is the drawing's sheet.
| |
Origin |
The view origin coordinates in the sheet.
| |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
Width |
The width of the view frame in paper coordinates.
|
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the view and its children objects from the database.
(Overrides DatabaseObjectDelete.) | |
GetAllObjects |
Gets all the objects and their children objects in the view.
| |
GetAllObjects(Type) |
Gets all the objects and their children objects in the view that are of a certain type.
| |
GetAllObjects(Type) |
Gets all the objects and their children objects in the view that are of certain types.
| |
GetAxisAlignedBoundingBox |
The view size in paper coordinates.
| |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetModelObjects |
Gets the drawing model objects based on given model object identifier.
If used from sheet model objects from all views are returned.
| |
GetObjects |
Gets the objects in the view. Does not return child objects (single dimensions, grid lines, views).
| |
GetObjects(Type) |
Gets the objects in the view that are of certain types. Does not return child objects (single dimensions, grid lines, views).
| |
GetOriginalDrawing |
Gets the drawing on which the view was originally created.
@see DrawingObject.GetDrawing() for retrieving the current drawing the object resides on.
| |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Inserts the view to the database.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the view in the database.
(Overrides DatabaseObjectModify.) | |
Select |
Selects the view from the database.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
See Also