UserPropertyItem Class |
The UserPropertyItem class contains information about the user properties in the Tekla Structures catalog.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
The UserPropertyItem type exposes the following members.
Constructors
Name | Description | |
---|---|---|
UserPropertyItem |
Creates a new user property item instance.
|
Properties
Name | Description | |
---|---|---|
AffectsNumbering |
Indicates whether the property value affects the numbering of objects.
| |
FieldType |
The field type of the user property.
| |
Level |
The level at which the user property has been defined.
| |
Name |
The name of the user property.
| |
Type |
The type of the user property.
| |
Unique |
Indicates whether the property value is copied when the object is copied.
| |
Visibility |
Indicates whether the property value is visible/editable.
|
Methods
Name | Description | |
---|---|---|
AddToObjectType |
Adds the user property item to the given object type.
| |
Delete |
Deletes the user property item from the database.
| |
GetDefaultValue(Double) |
Gets the default value of a double property.
| |
GetDefaultValue(Int32) |
Gets the default value of an integer property.
| |
GetDefaultValue(String) |
Gets the default value of a string property.
| |
GetLabel |
Gets the label of the user property. Labels are translated when translation is available.
| |
GetLabel(Boolean) |
Gets the label of the user property.
| |
GetObjectTypes |
Gets the object types which contain this user property item.
| |
GetOptions(ListKeyValuePairDouble, String) |
Gets the value options of a double property. Option strings are translated when translation is available.
| |
GetOptions(ListKeyValuePairInt32, String) |
Gets the value options of an integer property. Option strings are translated when translation is available.
| |
GetOptions(ListKeyValuePairString, String) |
Gets the value options of a string property. Option strings are translated when translation is available.
| |
GetOptions(ListKeyValuePairDouble, String, Boolean) |
Gets the value options of a double property.
| |
GetOptions(ListKeyValuePairInt32, String, Boolean) |
Gets the value options of an integer property.
| |
GetOptions(ListKeyValuePairString, String, Boolean) |
Gets the value options of a string property.
| |
Insert |
Inserts the user property item to the database.
| |
Modify |
Modifies the user property item.
| |
RemoveFromObjectType |
Removes the user property item from the given object type.
| |
Select |
Selects by name the user property item from the database.
| |
SetDefaultValue(Double) |
Sets the default value of a double property.
| |
SetDefaultValue(Int32) |
Sets the default value of an integer property.
| |
SetDefaultValue(String) |
Sets the default value of a string property.
| |
SetLabel |
Sets the label of the user property.
| |
SetOptions(ListKeyValuePairDouble, String) |
Sets the value options of a double property.
The maximum count of options is 400.
| |
SetOptions(ListKeyValuePairInt32, String) |
Sets the value options of an integer property.
The maximum count of options is 400.
| |
SetOptions(ListKeyValuePairString, String) |
Sets the value options of a string property.
The maximum count of options is 400.
|
See Also