UnitAttributes Class |
The UnitAttributes class handles attributes related to units and formatting of values.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The UnitAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
UnitAttributes |
Creates a new default UnitAttributes attributes instance. The default values are Units.Automatic, FormatTypes.Automatic.
| |
UnitAttributes(Units, FormatTypes) |
Creates a new UnitAttributes attributes instance with the given parameters.
|
Properties
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
| |
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also