TextFile Constructor (ViewBase, Point, String, Size, TextFileTextFileAttributes)

Creates a new text file instance using specific attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public TextFile(
	ViewBase view,
	Point insertionPoint,
	string fileName,
	Size size,
	TextFileTextFileAttributes attributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view for the object.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location of the object.
fileName
Type: SystemString
The name of the referenced text file.
size
Type: Tekla.Structures.DrawingSize
The maximum height of the text file object.
attributes
Type: Tekla.Structures.DrawingTextFileTextFileAttributes
The text file attributes to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next