TextFile Class

The TextFile class defines a text file object in a drawing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class TextFile : EmbeddedObjectBase, 
	IResizeable, IMovableRelative, IAxisAlignedBoundingBox, IObjectAlignedBoundingBox

The TextFile type exposes the following members.

Constructors
  NameDescription
Public methodTextFile(ViewBase, Point, String)
Creates a new text file instance using standard attributes.
Public methodTextFile(ViewBase, Point, String, Size)
Creates a new text file instance using standard attributes.
Public methodTextFile(ViewBase, Point, String, TextFileTextFileAttributes)
Creates a new text file instance using specific attributes.
Public methodTextFile(ViewBase, Point, String, Size, TextFileTextFileAttributes)
Creates a new text file instance using specific attributes.
Top
Properties
  NameDescription
Public propertyAttributes
Gets or sets the text file attributes.
Top
Methods
  NameDescription
Public methodDelete
Deletes the text file object.
(Overrides EmbeddedObjectBaseDelete.)
Public methodInsert
Inserts the text file object.
(Overrides EmbeddedObjectBaseInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides EmbeddedObjectBaseIsEqual(Object).)
Public methodModify
Modifies the text file object.
(Overrides EmbeddedObjectBaseModify.)
Public methodSelect
Selects the text file object.
(Overrides EmbeddedObjectBaseSelect.)
Top
Remarks
A text file object can be inserted as-is without scaling or it can be forced to fit inside the given space. The content is scaled in the Y direction, but it can overflow in the X direction.
Examples
The following example shows how to insert a text file object:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;
using System.IO;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase _sheet = MyDrawingHandler.GetActiveDrawing().GetSheet();

           TextFile text = new TextFile(_sheet, new Point(-300, 100), Path.GetFullPath("my_text.txt"));
           text.Insert();
       }
}
The following code inserts an object whose height is forced to 400 and width to 500, but it can overflow if the text is too long.
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;
using System.IO;

public class Example
{
       public void Example1()
       {
           Drawing myDrawing = new GADrawing();

           TextFile text = new TextFile(myDrawing.GetSheet(), new Point(-300, 100),
               Path.GetFullPath("my_text.txt"), new Size(500, 400));
           text.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next