TeklaStructuresSettings Class |
The TeklaStructuresSettings class provides methods to inquire application settings.
Inheritance Hierarchy
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The TeklaStructuresSettings type exposes the following members.
Constructors
Name | Description | |
---|---|---|
TeklaStructuresSettings | Initializes a new instance of the TeklaStructuresSettings class |
Methods
Name | Description | |
---|---|---|
GetAdvancedOption(String, Boolean) |
Returns the value of an advanced option variable.
| |
GetAdvancedOption(String, Double) |
Returns the value of an advanced option variable.
| |
GetAdvancedOption(String, Int32) |
Returns the value of an advanced option variable.
| |
GetAdvancedOption(String, String) |
Returns the value of an advanced option variable.
| |
GetAdvancedOptionPaths |
Gets the value of an advanced option as a list of valid paths.
Strings with path separator ; are split into separate paths and any blank paths (containing only white space) are ignored.
Paths do not need to exist but must use valid characters and format.
Note: All valid paths are returned even when invalid paths are encountered.
| |
GetOptions(ClashCheckOptions) |
Returns the value of the clash check options.
| |
GetOptions(ComponentOptions) |
Returns the value of the component options.
| |
IsPourEnabled |
Determines whether pour management is enabled.
| |
IsToolOptionOn |
Determines whether select switch is on.
| |
SetOptions(ClashCheckOptions) |
Sets the clash check options.
| |
SetOptions(ComponentOptions) |
Sets the component options.
|
See Also