Tekla.Structures.Model Namespace |
The Tekla.Structures.Model namespace includes the functionality to insert, select, modify or delete objects inside a Tekla Structures model. The namespace also includes possibilites to query different kind of data from the current model instance, such as information about the currently selected objects. The namespace offers the functionality through .NET remoting and the COM interface.
Classes
Class | Description | |
---|---|---|
Assembly |
The Assembly class defines a single manufacturing unit: objects that are bolted or welded together in the workshop.
An assembly has a main part and secondary assemblables attached to it. The number of secondaries is limited to 2048.
Hierarchical assemblies can also have subassemblies attached to them and they can have a parent assembly instance.
| |
BaseComponent |
The BaseComponent class is an abstract base class that represents generic components. The generic components
derived from the base component are the component, the connection, the detail and the seam.
| |
BasePoint |
The BasePoint class provides base point related functionalities. Base points can be retrieved using
ProjectInfo class.
| |
BaseRebarGroup |
The BaseRebarGroup class is an abstract base class that represents reinforcing bar group classes.
The reinforcing bar groups derived from the base group are the rebar group, the circled rebar group
and the curved rebar group.
| |
BaseRebarModifier |
Represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it.
| |
BaseWeld | The BaseWeld abstract class defines a weld between two model objects. | |
Beam |
The Beam class represents a single beam in the model.
A beam has a single start and end point.
| |
BendSurface |
The BendSurface class defines a surface contour that can be used as a bend between two plates
| |
BendSurfaceNode |
The BendSurfaceNode class represents a bend surface geometry tree node.
| |
BentPlate |
A class for the bent plate
| |
BentPlateGeometrySolver |
BentPlateGeometrySolver is a solver class to handle ConnectiveGeometry modification related computations.
| |
BoltArray |
The BoltArray class defines a bolt group with an array shape.
| |
BoltCircle |
The BoltCircle class defines a bolt group with a circle shape.
| |
BoltGroup |
The BoltGroup class is an abstract base class for all bolt shapes, such as array, circle and XY list.
See the Tekla Structures help file for further information about the attributes.
| |
BoltHoleAttributes |
The bolt hole attributes.
| |
BoltXYList |
The BoltXYList class defines a bolt group with an XY list shape. The bolt group is the most generic one
of the bolt groups.
| |
Boolean |
The Boolean class is an abstract base class for boolean operations such as a part cut, an add, a fitting or
a cut plane.
| |
BooleanPart |
The BooleanPart class represents a part cut or an add. This means that a model object is, for example,
cut with a part instance to create a void to the father part. Typically the operative part is deleted after
the boolean cut operation. In case of boolean add, operative part is deleted automatically.
| |
Brep |
The Brep class represents a single brep in the model.
A brep has a single start and end point.
| |
Chamfer |
The Chamfer class defines how the corners of a polybeam or a contour plate are rounded.
| |
ChangeData |
The ChangeData class presents information about the detected change of the modelobject in the model. It is instantiated inside the connected method.
| |
CircleRebarGroup |
The CircleRebarGroup class represents a group of reinforcing bars which have a circular shape.
| |
ClashCheckData |
The ClashCheckData class presents information about the detected clash. It is instantiated inside the onClashDetected method.
The objects store the identifiers and type of the clash to be passed on to event subscribers.
| |
ClashCheckHandler |
The ClashCheckHandler class contains clash check methods.
| |
Component |
The Component class represents a component. A component is a modelling tool that typically
assembles multiple parts to build some type of a structure, for example a hall macro or at a
smaller scale a reinforcement component (a macro). Also, a custom part is a component.
| |
ComponentInput |
The ComponentInput class handles the input of component objects and positions. A component has one component input.
The component input must include all the needed input objects and points in the correct order. For example,
an input with a point and a part is different from an input of a part and a point.
The maximum number of different input items in the collection is 10.
| |
ConicalSurface |
The ConicalSurface class defines a conical surface contour.
| |
ConicalSurfaceNode |
The ConicalSurfaceNode class represents conical surface geometry tree node.
| |
Connection |
The Connection class represents a connection. A connection is something that connects two or more parts together.
| |
ConnectiveGeometry |
A class for geometry formed of several geometry sections. Geometry is initialized with polygon geometry
and then can be extended by calling one of AddLeg methods using BentPlateGeometrySolver class.
In the case of success, two polygon geometries will be connected by cylindrical surface geometry possibly
with help of additional polygon geometries.
Resulted geometry, then, can be set to bent plate.
| |
ConnectiveGeometryException |
The ConnectiveGeometryException class represents an error that occurred during the ConnectiveGeometry creation or modification.
| |
Contour |
The Contour class defines a possibly chamfered contour. Contours must not have loops.
| |
ContourPlate |
The ContourPlate class represents a part made with a contour, such as, a concrete slab.
| |
ContourPoint |
The ContourPoint class defines a point with possible chamfering information,
used, for example, to define a contour plate.
| |
ControlArc |
The ControlArc class defines a user defined arc helping in modeling work.
| |
ControlCircle |
The ControlCircle class defines a user defined (not magnetic) circle helping in modeling work.
If there are duplicated input points or 3 input points are in a line, ControlCircle.Insert() will return false.
ControlCircle.Select() will return the center point of the circle to Point1.
| |
ControlLine |
The ControlLine class defines a user defined (possibly magnetic) line helping in modeling work.
| |
ControlPlane |
The ControlPlane class defines a user defined (possibly magnetic) plane helping in modeling work.
| |
ControlPoint |
The ControlPoint class defines a user defined point helping in modeling work.
| |
ControlPolycurve |
The ControlPolycurve class defines a user defined polycurve object which contains a chain of line and arc geometries.
| |
CurvedRebarGroup |
The CurvedRebarGroup class represents a group of reinforcing bars which have a curved shape.
| |
CustomPart |
The CustomPart class represents a custom part object in the Tekla Structures model.
A custom part is a modeling tool that typically assembles multiple parts to build some
type of a beam-like structure, for example a tapered beam or a sandwich panel.
| |
CutPlane |
The CutPlane class defines how the end of a part is cut with a plane. A cut plane differs from a fitting because
a cut can never extend the boundaries of the original part.
| |
CylindricalSurface |
The CylindricalSurface class defines a cylindrical surface contour.
| |
CylindricalSurfaceNode |
The CylindricalSurfaceNode class represents cylindrical surface geometry tree node.
| |
DeformingData |
The DeformingData class holds information about the deforming of parts.
Deformed parts are parts that have been warped, cambered or shortened.
| |
Detail |
The Detail class represents a detail. A detail is different from a connection since the detail only connects to one part.
| |
DisposableToken | IDisposable delegate adapter.
| |
EdgeChamfer |
The EdgeChamfer class defines how the part edge is chamfered.
| |
Events |
The Events class allows the user to register event listeners for model events.
| |
ExtensionIntersectsWithPlateException |
The ExtensionIntersectsWithPlateException class represents an error when extension plate clashes with plates.
| |
FacePerpendicularToIntersectionLineException |
The FacePerpendicularToIntersectionLineException class represents an error when, face perpendicular to intersection line.
| |
FacesAtAnObtuseAngleException |
The FacesAtAnObtuseAngleException class represents an error when, faces to be connected are too steep of an angle.
| |
FacesTooNearEachOtherException |
The FacesTooNearEachOtherException class represents an error when, faces to be connected overlap.
| |
Fitting |
The Fitting class defines how the part end fits to a plane. A fitting can make the part either longer or shorter.
| |
GeneralConnectiveGeometryException |
The GeneralConnectiveGeometryException class represents a general error that occurred during the ConnectiveGeometry creation or modification.
| |
GeometrySection |
The GeometrySection class represents geometry node with its identifier.
| |
GeometrySectionEnumerator |
The GeometrySectionEnumerator class is used to enumerate the geometry sections of a bent plate geometry.
| |
Grid |
The Grid class defines a user defined (possibly magnetic) set of planes helping in modeling work. A grid has grid plane
instances as children.
| |
GridBase |
The GridBase class defines the base class for grids.
| |
GridCylindricalSurface |
The GridCylindricalSurface class defines a user defined (possibly magnetic) cylindrical surface helping in
modeling work. A grid cylindrical surface must always belong to a parent grid instance.
| |
GridPlane |
The GridPlane class defines a user defined (possibly magnetic) plane helping in modeling work. A grid plane must
always belong to a father grid instance.
| |
GridSurface |
The GridSurface class defines a user defined (possibly magnetic) surface helping in modeling work. A grid surface must
always belong to a parent GridBase instance.
| |
HierarchicDefinition |
The HierarchicDefinition class defines a hierarchy structure. This hierarchy structure can
be instantiated and extended by hierarchical objects.
| |
HierarchicObject |
The HierarchicObject class defines an object in a tree-structured hierarchy. The hierarchy structure is defined
by hierarchical definitions which the hierarchical objects instantiate. Hierarchical objects may contain
other hierarchical objects, thus forming a sub-hierarchy, or model objects.
| |
InputItem |
The InputItem class is used to store input objects and positions.
| |
InvalidCurveCombinationException |
This class represent an exception thrown when the combination of base curves is not allowed in a lofted plate
operation
| |
InvalidFacePointsException |
The InvalidFacePointsException class represents an error when, cannot create geometry from requested face points.
| |
InvalidRadiusException |
The InvalidRadiusException class represents an error when, cannot connect parts with a cylindrical section having the provided radius.
| |
Load |
The Load class is an abstract base class for all loads.
| |
LoadArea |
The LoadArea class defines a linearly-distributed force bound by a triangle or a quadrangle.
| |
LoadGroup |
The LoadGroup class implements grouping functionality related to all loads.
Each load should be assigned to a load group. Each load group contains loads
caused by the same action and to which you want to refer collectively.
Tekla Structures assumes that all loads in a group
You may create new load groups, modify existing ones and delete load groups via the .NET interface. You may also change the assigned load group of a load and list all the load groups found in the model via the ModelObjectSelector interface. The model always has at least one load group. | |
LoadLine |
The LoadLine class defines a linearly-distributed force or torsion.
| |
LoadPoint |
The LoadPoint class defines a concentrated force or a bending moment.
| |
LoadTemperature |
The LoadTemperature class defines a temperature change in a part, or a temperature difference between two part surfaces.
| |
LoadUniform |
The LoadUniform class defines a uniformly-distributed force bounded by a polygon.
| |
LoftedPlate |
This class represents a lofted plate
| |
LoftedPlateOperationException |
This empty class serves as a base (marker class) for all the exception thrown in lofted plate operations
| |
LogicalWeld |
The LogicalWeld class represents a group of welds in the model.
A logical weld contains a list of children welds.
The primary properties need to be the same in all the children welds.
| |
Material |
The Material class represents a single material that parts can be made of.
| |
Model |
The Model class represents a single model open in Tekla Structures.
Before interaction with the model, the user will have to create one
instance of this class.
| |
ModelHandler |
The ModelHandler class provides information about the currently open Tekla Structures
model.
| |
ModelInfo |
The ModelInfo class provides information about the currently open Tekla Structures
model.
| |
ModelObject |
The ModelObject class is an abstract base class for all model objects, such as parts, bolts,
welds and reinforcements.
| |
ModelObjectEnumerator |
The ModelObjectEnumerator class provides the means to iterate through model object instances in the
current model.
| |
ModelObjectSelector |
The ModelObjectSelector class can be used to make different model object selections
from the current model.
| |
NullRulingException |
This class represent an exception thrown when a ruling of the lofted plate (i.e. the lines that swipe the plate
surface between the base curves) would become zero because of a lofted plate operation
| |
NumberingSeries |
The NumberingSeries class describes how an object is to be numbered.
| |
NumberingSeriesNullable |
The NumberingSeriesNullable class describes how an object is to be numbered.
| |
Object |
The Object class is an abstract base class for all the objects Tekla Structures has.
| |
Offset |
The Offset class defines the offset value of start points and end points. The offset is the
distance from the current work plane in the three global directions.
| |
Part |
The Part class represents a part in the model.
A part can be either a beam, a polybeam or a contour plate.
| |
Phase |
The Phase class defines a model object phase.
| |
PhaseCollection |
The PhaseCollection class handles the collection of the model phases.
| |
Plane |
The Plane class defines a plane in space using an origin, an X-axis and a Y-axis.
| |
PlateIntersectsWithIntersectionLineException |
The PlateIntersectsWithIntersectionLineException class represents an error when, plate polygon extends beyond intersection line.
| |
PointCloud |
Initializes a new instance of the PointCloud class.
| |
PolyBeam |
The PolyBeam class represents a continuous beam with a contour as input.
| |
Polygon | The Polygon class represents a polygon object that has its corners at the given points. | |
PolygonNode |
The PolygonNode class represents flat geometry tree node.
| |
PolygonWeld |
The PolygonWeld class represents a polygon weld in the model.
A polygon weld has a main part and a secondary part.
| |
Polymesh | The Polygon class represents a polygon object that has its corners at the given points. | |
PolymeshEnumerator |
The PolymeshEnumerator class is used to enumerate the polymesh of a pour's merged faces.
| |
Position |
The Position class defines how a part is positioned relative to the input.
| |
PourBreak |
The PourBreak class represents a pour break in a model.
| |
PourObject |
The PourObject class represents a pour object in the model.
| |
PourUnit |
The PourUnit class represents a pour unit in the model.
| |
Profile |
The Profile class defines the form of a cross section.
| |
ProjectInfo |
The ProjectInfo class provides project information about the currently open Tekla Structures model.
| |
RadialGrid |
The RadialGrid class defines a user defined (possibly magnetic) set;
radial grid has grid planes and cylindrical grid planes as children
| |
RebarComplexGeometry |
The ReinforcingBar class represents a single physical reinforcing bar. It contains the curves
and bendings that define the geometry of the bar.
| |
RebarCranking |
The RebarCranking class represents the cranking of reinforcing bars at a RebarSplitter.
| |
RebarCrankingNullable |
The RebarCrankingNullable class represents the cranking of reinforcing bars at a RebarEndDetailModifier.
| |
RebarEndDetailModifier |
The RebarEndDetailModifier class represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it.
It can modify reinforcing bar end properties and will therefore affect the end of the reinforcing bars it is nearest to.
| |
RebarGeometry |
The RebarGeometry class represents a single physical reinforcing bar - the building block of
a mesh, a rebar group and even a single rebar.
It contains the physical reinforcing bar points in 3D space.
| |
RebarGroup |
The RebarGroup class represents a group of reinforcing bars.
| |
RebarGuideline | ||
RebarHookData |
The RebarHookData class defines the hook at the end of a reinforcing bar.
Hooks are used for anchoring purposes.
| |
RebarHookDataNullable |
The RebarHookDataNullable class defines the hook at the end of a reinforcing bar. Hooks are used for anchoring purposes.
| |
RebarLapping |
The RebarLapping class represents the lapping of reinforcing bars at a RebarSplitter.
| |
RebarLeg |
This represents a leg of a rebar and is used in the RebarComplexGeometry class.
| |
RebarLegFace | ||
RebarLegSurfaceObject |
The RebarLegSurfaceObject class represents a polymesh surface for generating rebar legs in a RebarSet.
| |
RebarLengthAdjustmentDataNullable |
The RebarLengthAdjustmentDataNullable class defines the length adjustment at the end of a reinforcing bar affected by a RebarEndDetailModifier.
If a length adjustment property is null then that property will not be applied to the RebarSet generated reinforcing bars.
| |
RebarMesh |
The RebarMesh class represents a reinforcement mesh.
| |
RebarProperties |
The RebarProperties class defines the default properties of the reinforcing bars in a RebarSet.
| |
RebarPropertiesNullable |
The RebarPropertiesNullable class defines the properties of the reinforcing bars affected by a RebarPropertyModifier.
| |
RebarPropertyModifier |
The RebarPropertyModifier class represents a modifier that can modify the characteristics of RebarSet reinforcing bars that pass through it.
| |
RebarSet |
The RebarSet class represents a set of reinforcing bars.
| |
RebarSetAddition |
The RebarSetAddition class can be used to add RebarLegFace objects to an existing RebarSet.
| |
RebarSpacing |
The RebarSpacing class defines spacing properties for a RebarGuideline.
| |
RebarSpacingExactSpacing |
This class defines objects used in the exact spacing type.
| |
RebarSpacingZone |
The RebarSpacingZone class defines the properties of a single spacing zone.
The spacing properties of number of spaces, spacing and length are proposed properties that the spacing algorithm uses as input when calculating the
final reinforcing bars spacing.
Depending on the RebarSpacingZone properties and any other rebar spacing zones defined on the associated RebarGuideline the spacing algorithm may
determine a different final reinforcing bars spacing from the original proposed properties. However the RebarSpacingZone properties will always contain the
original proposed values.
| |
RebarSplice |
The RebarSplice class represents a splice between two reinforcements.
| |
RebarSplitter |
The RebarSplitter class represents a modifier that can split the RebarSet reinforcing bars that pass through it.
| |
RebarStrand |
The RebarStrand class represents prestressed strands for concrete parts.
| |
RebarThreadingDataNullable |
The RebarThreadingDataNullable class defines the threading properties at the end of a reinforcing bar affected by a RebarEndDetailModifier.
If a threading property is null then that property will not be applied to the RebarSet generated reinforcing bars.
| |
ReferenceModel |
The ReferenceModel class contains methods related to reference models.
A reference model is a reference of an external model.
| |
ReferenceModelObject |
The ReferenceModelObject class contains methods related to reference model objects.
A reference model object is a subobject of a reference model.
| |
Reinforcement |
The Reinforcement class represents a reinforcement in the model. A reinforcement can either be a mesh,
a single rebar, a rebar group or a strand.
| |
Seam |
The Seam class represents a seam. A seam is something that connects a main part to other parts along an edge.
| |
SelfIntersectingSurfaceException |
This class represent an exception thrown when the an operation on a lofted plate has been determined to cause
a self intersecting surface
| |
SingleRebar |
The SingleRebar class represents a single reinforcing bar.
| |
Solid |
The Solid class represents the physical object in the model created by a part instance.
A solid instance can be used to query the actual geometry of the part and intersect that
geometry with, for example, lines and planes.
| |
SpiralBeam |
A class for the spiral beam part.
| |
SpiralBeamDataException |
The SpiralBeamDataException class represents an error that occurred during the spiral beam creation or modification.
| |
StrandUnbondingData |
The StrandUnbondingData class represents the unbonding of a rebar strand.
| |
SurfaceObject |
The SurfaceObject class represents a surface object in the model. Currently this class
only support dynamic surfaces whose geometries are determined by the parts or pours
they associate to. It is not allowed to modify the geometry of a dynamic surface on Open API.
The polymesh setter of this class throws .
| |
SurfaceTreatment |
The SurfaceTreatment class defines a layer above a building element defining what a surface looks like.
The surface could for example have a tiled look.
| |
Task |
The Task class defines a single building site task. It may contain parts, assemblies or other tasks. Tasks may
have a hierarchy between them i.e. there are other tasks as subtasks for a parent task. Tasks may also
depend on each other, have resources assigned to them or have a single worktype.
| |
TaskDependency |
The TaskDependency class represents a dependency between two task objects. Each task may depend
on many other tasks, but between two specific tasks only one type of a dependency may exist.
There are four types of dependencies:
| |
TaskWorktype |
The TaskWorktype class defines a single worktype for a task object. Each task may belong to only
one worktype.
| |
TransformationPlane |
The TransformationPlane class describes a transformation from global model coordinates
to local and back to global.
| |
UndefinedCurveDirectionException |
The UndefinedCurveDirectionException class represents an error when, cannot make inward/outward curve check.
| |
UnknownLoftedPlateErrorException |
This class represent an exception thrown when an operation on a lofted plate caused an error of unknown origin
| |
UnsupportedChamferException |
The UnsupportedChamferException class represents an error when, plates containing unsupported chamfer information.
| |
Weld |
The Weld class represents a normal weld in the model.
A normal weld has a main part and a secondary part.
| |
WorkPlaneHandler |
The WorkPlaneHandler class contains methods for getting and setting
the current transformation plane.
|
Structures
Structure | Description | |
---|---|---|
RebarSpacingExactSpacingElement |
This structure is used to hold number and distance data.
| |
RebarSpacingOffset |
Defines parameters associated with the start and end of the spacing.
| |
ReferenceModelRevision |
Reference model revision.
|
Interfaces
Interface | Description | |
---|---|---|
IAssemblable |
The IAssemblable interface dictates which model objects are capabable of belonging to an assembly at the leaf level.
| |
IGeometryNode |
The IGeometryNode interface represents geometry tree node. This is implemented by concrete classes for the various types of geometry nodes
| |
IGeometryNodeVisitor |
The IGeometryNodeVisitor interface is implemented by classes visiting geometry nodes
|
Delegates
Delegate | Description | |
---|---|---|
EventsClashCheckDoneDelegate |
The delegate to use for clash check completion.
| |
EventsClashDetectedDelegate |
The delegate to use for clash detection.
Encapsulates any method that takes a clash check data object as a parameter.
| |
EventsCommandStatusChangeDelegate |
The delegate to use for command status change.
| |
EventsInterruptedDelegate |
The delegate to use for interrupted event
| |
EventsModelChangedDelegate |
The delegate to use for database commit.
| |
EventsModelLoadDelegate |
The delegate to use for model load.
| |
EventsModelLoadInfoDelegate |
The delegate to use for extended model load.
| |
EventsModelObjectChangedDelegate |
The delegate to use for changed model objects.
ModelObject inside ChangeData contains only identifier information. If properties need to be checked, Select() for object is required.
| |
EventsModelObjectNumberedDelegate |
The delegate to use for model objects which are numbered.
ModelObjects contain only identifier information. If properties need to be checked, Select() for object is required.
| |
EventsModelSaveAsDelegate |
The delegate to use for model save as.
| |
EventsModelSaveDelegate |
The delegate to use for model save.
| |
EventsModelSaveInfoDelegate |
The delegate to use for model save with context information.
| |
EventsNumberingDelegate |
The delegate to use for numbering.
| |
EventsProjectInfoChangedDelegate |
The delegate to use for change in project info.
| |
EventsSelectionChangeDelegate |
The delegate to use for selection change.
| |
EventsTeklaStructuresExitDelegate |
The delegate to use for Tekla Structures exit.
| |
EventsViewCameraChangedDelegate |
The delegate to use for view camera changed event
|
Enumerations
Enumeration | Description | |
---|---|---|
AssemblyAssemblyTypeEnum |
The assembly types.
| |
BasePointCoordinateSystemType |
The type of the base points coordinate system.
| |
BaseRebarGroupExcludeTypeEnum |
The different ways to exclude reinforcing bars from the group.
| |
BaseRebarGroupRebarGroupSpacingTypeEnum |
The ways to distribute the reinforcing bars with different spacings.
| |
BaseRebarModifierAffectedRebarEnum |
This enum allows the caller to specify which end of the bar is of interest when calling the function GetAffectedBars.
| |
BaseRebarModifierBarsAffectedEnum |
The reinforcing bars affected.
| |
BaseWeldWeldContourEnum | The weld contour. | |
BaseWeldWeldElectrodeClassificationEnum | The weld electrode classification. | |
BaseWeldWeldFinishEnum | The weld finish. | |
BaseWeldWeldIntermittentTypeEnum |
Weld intermittent types.
| |
BaseWeldWeldNDTInspectionEnum | The weld NDT inspection level. | |
BaseWeldWeldPlacementTypeEnum |
Weld placement types.
| |
BaseWeldWeldPreparationTypeEnum |
Weld preparation types.
| |
BaseWeldWeldProcessTypeEnum | The weld process type. | |
BaseWeldWeldTypeEnum | The weld types. | |
BeamBeamTypeEnum |
The beam types.
The strip and pad footings are valid only if the material type of the beam is concrete.
| |
BentPlateBendShape |
Enumerator to define different possibilities for bend shapes.
| |
BentPlateGeometrySolverOperationStatus |
Define possible statuses for geometry creation/modification commands.
| |
BoltGroupBoltHoleTypeEnum |
The special hole type.
| |
BoltGroupBoltPlainHoleTypeEnum |
The plain hole type.
| |
BoltGroupBoltRotateSlotsEnum |
The rotation of the slots (the holes).
| |
BoltGroupBoltThreadInMaterialEnum |
The thread in the material.
| |
BoltGroupBoltTypeEnum |
The type of the bolt.
| |
BoltGroupErrorStatus |
Define possible statuses for geometry creation/modification commands.
| |
BooleanPartBooleanTypeEnum |
Defines the boolean operation: an add or a cut.
| |
ChamferChamferTypeEnum |
The basic shape type of the chamfer.
| |
ChangeDataChangeSourceTypeEnum |
The source types of changed event.
| |
ChangeDataChangeTypeEnum |
The types of changed event.
| |
CircleRebarGroupCircleRebarGroupStirrupTypeEnum | The different stirrup types. | |
ClashCheckDataClashTypeEnum |
An enumeration for the different clash types.
| |
ContourPlateContourPlateTypeEnum |
The contour plate types.
| |
ControlCircleControlCircleColorEnum |
The different circle colors.
| |
ControlLineControlLineColorEnum |
The different line colors.
| |
ControlObjectColorEnum |
The different colors used for control objects (ControlLine and ControlCircle have their own).
| |
ControlObjectLineType |
The line types (the presentation of the line).
| |
EdgeChamferChamferEndTypeEnum | The end type of the edge chamfer. | |
HierarchicDefinitionTypeEnum |
Defines the different types of classification hierarchies.
| |
InputItemInputTypeEnum |
Defines the type of the input.
| |
LoadLoadAttachmentEnum |
The load attachment.
| |
LoadLoadPartNamesEnum |
The load part names.
| |
LoadLoadSpanningEnum |
The load spanning.
| |
LoadAreaAreaLoadFormEnum |
The area load form.
| |
LoadGroupColors |
The possible display colors for loads in a load group.
| |
LoadGroupLoadGroupDirection |
The possible directions.
| |
LoadGroupLoadGroupType |
The possible types for load groups.
| |
LoadLineLineLoadFormEnum |
The line load form.
| |
LoftedPlateLoftedPlateFaceTypeEnum |
Lofted plate solid creation face types.
| |
ModelObjectModelObjectEnum |
All possible concrete model object subclasses are defined here. This enumeration can be used to
fetch certain types of objects from the Tekla Structures model.
| |
ModelObjectEnumeratorEnumeratorTypeEnum |
The types of enumerator available.
| |
PartCastUnitTypeEnum |
The cast unit types.
| |
PolyBeamPolyBeamTypeEnum |
The polybeam types.
| |
PolymeshPolymeshCheckerFlags |
Polymesh check flags, please refer to PolymeshHealthCheckEnum for the corresponding result values.
| |
PolymeshPolymeshHealthCheckEnum |
Polymesh check error result codes. See the PolymeshCheckerFlags to see how to set the various checks.
| |
PositionDepthEnum |
The position in the depth sense.
| |
PositionPlaneEnum |
The position in the plane sense.
| |
PositionRotationEnum |
The position in the rotational sense.
| |
RebarCrankingCrankedLengthTypeEnum |
The cranked length type.
| |
RebarCrankingCrankingTypeEnum |
The cranking type.
| |
RebarCrankingCrankSideEnum |
The crank side.
| |
RebarCrankingNullableEndCrankingTypeEnum |
The end cranking type.
| |
RebarEndDetailModifierEndTypeEnum |
The end type.
| |
RebarGroupRebarGroupStirrupTypeEnum | The different stirrup types. | |
RebarHookDataRebarHookShapeEnum |
The different hook shapes.
| |
RebarLappingLappingTypeEnum |
The lapping type.
| |
RebarLappingLapPlacementEnum |
The placement of the lap relative to the associated RebarLegFace.
| |
RebarLappingLapSideEnum |
The side of the split that the lap is located.
| |
RebarLegOriginEnum |
Enumerator for different leg origins.
| |
RebarLengthAdjustmentDataNullableLengthAdjustmentTypeEnum |
The length adjustment type.
| |
RebarMeshRebarMeshCrossBarLocationEnum |
The ways to locate the crossing bars.
| |
RebarMeshRebarMeshSpacingMethodEnum |
The ways to distribute the reinforcing bars with different spacings.
| |
RebarMeshRebarMeshTypeEnum |
The different types of reinforcement meshes.
| |
RebarPropertyModifierGroupingTypeEnum |
The grouping type.
| |
RebarSpacingExactSpacingValidation |
Defines values used in validation of exact spacing elements.
| |
RebarSpacingExcludeTypeEnum |
The different ways to exclude reinforcing bars from the spacing.
| |
RebarSpacingOffsetEnum |
The offset distance type.
| |
RebarSpacingSpacingType |
Defines the different spacing types.
| |
RebarSpacingZoneLengthEnum |
The length type.
| |
RebarSpacingZoneSpacingEnum |
The spacing type.
| |
RebarSpliceRebarSpliceBarPositionsEnum |
The bar group positions in the splice.
| |
RebarSpliceRebarSpliceTypeEnum |
The splice types.
| |
RebarSplitterSplitTypeEnum |
The split type.
| |
RebarSplitterStaggerTypeEnum |
The side of the split that the additional offset (stagger) is located.
| |
ReferenceModelVisibilityEnum |
The visibility type.
| |
ReinforcementRebarGeometryOptionEnum |
Options for the function GetRebarGeometries.
| |
ReinforcementRebarGeometrySimplificationTypeEnum |
The rebar geometry simplification type.
| |
ReinforcementRebarOffsetTypeEnum |
The different types of offsets.
| |
SolidSolidCreationTypeEnum |
The creation type of the solid.
| |
SpiralBeamErrorStatus |
Define possible statuses for geometry creation/modification commands.
| |
SurfaceTreatmentSurfaceColorEnum |
The different surfacing colors.
| |
SurfaceTreatmentSurfaceTypeEnum |
The different surfacing types.
| |
TaskDependencyDependencyTypeEnum |
The task dependency types.
| |
WeldWeldPositionEnum | The weld position. |