TeklaStructuresDatabaseTypeEnum Enumeration |
The object types to be used in filter expressions.
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
UNKNOWN | 0 | The unknown type. | |
POINT | 1 | The point type, this is not a ModelObject. | |
PART | 2 | The part type. | |
CONNECTION | 3 | The connection type, used for details and seams as well. | |
COMPONENT | 4 | The component type, used for macros, plug-ins and custom parts. | |
GRID | 7 | The grid type. | |
FITTING | 9 | The fitting type. | |
BOLT | 10 | The bolt type. | |
PART_CUT | 11 | The part cut type. | |
PLANE_CUT | 12 | The plane cut type. | |
WELDING | 13 | The welding type. | |
ASSEMBLY | 15 | The assembly type. | |
CONSTRUCTION_LINE | 24 | The construction line type, this is not a ModelObject. | |
PLANE | 30 | The plane type, used for control planes and grid planes. | |
DRAWING | 34 | The drawing. | |
DB_CONNECTION | 35 | The connection type. | |
PART_ADD | 38 | The part add type. | |
WELD_CUT | 39 | The weld preparation. | |
CONSTRUCTION_CIRCLE | 42 | The construction circle type, this is not a ModelObject. | |
CONSTRUCTION_ARC | 43 | The construction arc | |
DB_COMPONENT | 46 | The component type. | |
REBAR | 47 | The rebar type, used for single rebars, groups, meshes and strands. | |
FOREIGN_OBJECT | 48 | The foreign object. | |
LOAD_LOAD | 49 | The load type. | |
LOAD_POINT | 50 | The load point type. | |
LOAD_LINE | 51 | The load line type. | |
LOAD_AREA | 52 | The load area type. | |
LOAD_UNIFORM | 53 | The load uniform type. | |
LOAD_GROUP | 54 | The load group type. | |
LOAD_TEMPERATURELOAD | 72 | The temperature load type. | |
SURFACE_TREATMENT | 73 | The surface treatment type. | |
REBAR_SPLICE | 74 | The rebar splice type. | |
ANALYSIS_MODEL | 75 | The analysis model. | |
ANALYSIS_PART | 76 | The analysis part. | |
ANALYSIS_NODE | 77 | The analysis node. | |
EDGE_CHAMFER | 79 | The edge chamfer type. | |
TASK | 80 | The task type. | |
TASK_DEPENDENCY | 81 | The task dependency type. | |
TASK_WORKTYPE | 83 | The task worktype type. | |
HIERARCHIC_DEFINITION | 84 | The hierarchic definition type. | |
HIERARCHIC_OBJECT | 85 | The hierarchic object type. | |
DB_POUR_BREAK | 89 | The pour break type. | |
DB_POUR_OBJECT | 90 | The pour object type. | |
REBARSET_ADDITION | 95 | The rebar set addition type. | |
REBARSET_MODIFIER | 96 | The rebar set modifier type. | |
SURFACE_OBJECT | 97 | The surface object type | |
BENT_PLATE | 98 | The bent plate type | |
HELIX | 99 | The helix type | |
DB_POUR_UNIT | 101 | The pour unit type | |
CONSTRUCTION_POLYCURVE | 103 | The construction polycurve | |
STOREY | 104 | Building Hierarchy Storey | |
BUILDING_SITE | 105 | Building Hierarchy Building | |
BUILDING | 106 | Building Hierarchy Site | |
SPACE | 108 | Building Hierarchy Space |
See Also