Tekla.Structures.Analysis Namespace

The Tekla.Structures.Analysis namespace provides basic classes that can be used for accessing analysis and design information in Tekla Structures.
Classes
  ClassDescription
Public classCode exampleAnalysis
The Analysis class is a class from which the user can query analysis instances.
Public classAnalysisArea
The AnalysisArea class contains information related to analysis areas.
Public classAnalysisAreaPolygon
The AnalysisAreaPolygon class contains information related to analysis area polygons.
Public classAnalysisBar
The AnalysisBar class contains information related to analysis bars.
Public classAnalysisBeamEnd
The AnalysisBeamEnd class contains information related to analysis beam ends.
Public classAnalysisCompositeBeam
The AnalysisCompositeBeam class contains information related to analysis composite beams.
Public classAnalysisConnectivity
The AnalysisConnectivity class contains information related to analysis connectivities.
Public classAnalysisCrossSection
The AnalysisCrossSection class contains information related to analysis cross sections.
Public classAnalysisCurvature
The AnalysisCurvature class contains information related to analysis curvatures.
Public classAnalysisDecomposedAreaLoad
The AnalysisDecomposedAreaLoad class contains decomposed area load information.
Public classAnalysisDecomposedBarLoad
The AnalysisDecomposedBarLoad class contains information related to decomposed bar loads.
Public classAnalysisDecomposedLoad
The AnalysisDecomposedLoad class contains information related to decomposed loads.
Public classAnalysisDecomposedMemberLoad
The AnalysisDecomposedMemberLoad class contains information related to decomposed member loads.
Public classAnalysisDecomposedNodeLoad
The AnalysisDecomposedNodeLoad class contains information related to decomposed node loads.
Public classAnalysisDecomposedSelfweightLoad
The AnalysisDecomposedSelfweightLoad class contains information of decomposed selfweight loads.
Public classAnalysisDecomposedTemperatureLoad
The AnalysisDecomposedTemperatureLoad class contains information related to decomposed temperature loads.
Public classAnalysisDeltaZ
The AnalysisDeltaZ class contains delta Z information for an analysis model.
Public classAnalysisDesignCode
The AnalysisDesignCode class contains information related to analysis design codes.
Public classAnalysisDesignParameter
The AnalysisDesignParameter class contains information related to analysis design parameters.
Public classAnalysisDesignParameterBase
The AnalysisDesignParameterBase class contains base information related to analysis design parameters.
Public classAnalysisDesignParameterMulti
The AnalysisDesignParameterMulti class contains information related to analysis design parameters with multi values.
Public classAnalysisDesignSettings
The AnalysisDesignSettings class contains information about analysis design settings.
Public classAnalysisEccentricity
The AnalysisEccentricity class contains eccentricity information for an analysis model.
Public classAnalysisEdge
The AnalysisEdge class contains information related to analysis edges.
Public classAnalysisFace
The AnalysisFace class contains information related to analysis faces.
Public classAnalysisLabel
The AnalysisLabel class contains information related to analysis labels.
Public classAnalysisLoadCombination
The AnalysisLoadCombination class contains information related to analysis load combinations.
Public classAnalysisLoadGroup
The AnalysisLoadGroup class contains information related to analysis load groups.
Public classAnalysisLocalCoordinateSystem
The AnalysisLocalCoordinateSystem class contains local coordinate system information for an analysis model.
Public classAnalysisMaterial
The AnalysisMaterial class contains the material information.
Public classAnalysisMember
The AnalysisMember class contains information related to analysis members.
Public classCode exampleAnalysisModel
The AnalysisModel class contains information related to analysis models.
Public classAnalysisModelAnalysisProperties
The AnalysisModelAnalysisProperties class contains the analysis property information for an analysis model.
Public classAnalysisModelConnectivityRule
The AnalysisModelConnectivityRule class contains information related to analysis model connectivity rules.
Public classAnalysisModelDesignProperties
The AnalysisModelDesignProperties class contains information related to analysis model design properties.
Public classAnalysisModelGeneralProperties
The AnalysisModelGeneralProperties class contains the general property information for an analysis model.
Public classCode exampleAnalysisModelHandler
The AnalysisModelHandler class contains information related to analysis models.
Public classAnalysisModelIssue
Analysis model issue (error, warning, information)
Public classAnalysisModelJobProperties
The AnalysisModelJobProperties class contains information related to analysis model job properties.
Public classAnalysisModelLoad
The AnalysisModelLoad class contains information related to the model loads that are included in the analysis model. The identifier is the identifier of the Tekla.Structures.Model object.
Public classAnalysisModelModalAnalysisProperties
The AnalysisModelModalAnalysisProperties class contains information related to analysis model modal analysis properties.
Public classAnalysisModelOutputProperties
The AnalysisModelOutputProperties class contains information related to analysis model output properties.
Public classAnalysisModelSeismicProperties
The AnalysisModelSeismicProperties class contains information related to analysis model seismic properties.
Public classAnalysisModelSpectrumProperties
The AnalysisModelSpectrumProperties class contains information related to analysis model spectrum properties.
Public classAnalysisNode
The AnalysisNode class contains information related to analysis nodes.
Public classAnalysisNodeLink
The AnalysisNodeLink class contains information related to analysis node links.
Public classAnalysisObject
The AnalysisObject class is an abstract base class for all analysis objects.
Public classAnalysisObjectEnumerator
The AnalysisObjectEnumerator class provides the means to iterate through analysis object instances.
Public classAnalysisObjectSelector
The AnalysisObjectSelector class contains methods for getting objects.
Public classAnalysisPart
The AnalysisPart class contains information related to analysis parts.
Public classAnalysisPartAnalysisProperties
The AnalysisPartAnalysisProperties class contains information related to analysis part analysis properties.
Public classAnalysisPartAreaAttributes
The AnalysisPartAreaAttributes class contains information related to analysis part area attributes.
Public classAnalysisPartBarAttributes
The AnalysisPartBarAttributes class contains information related to analysis part bar attributes.
Public classAnalysisPartCompositeProperties
The AnalysisPartCompositeProperties class contains information related to analysis part composite properties.
Public classAnalysisPartEnd
The AnalysisPartEnd class contains information related to analysis part ends.
Public classAnalysisPartLoadingProperties
The AnalysisPartLoadingProperties class contains information related to analysis part loading properties.
Public classAnalysisPartPositionProperties
The AnalysisPartPositionProperties class contains information related to analysis part position properties.
Public classAnalysisPartSpanningProperties
The AnalysisPartSpanningProperties class contains information related to analysis part spanning properties.
Public classAnalysisPosition
The AnalysisPosition class contains information related to analysis positions.
Public classAnalysisRestraintData
The AnalysisRestraintData class contains the restraint data for an analysis part.
Public classAnalysisRestraints
The AnalysisRestraints class contains analysis restraints information for an analysis part.
Public classCode exampleAnalysisResult
The AnalysisResult class contains analysis result information.
Public classCode exampleAnalysisResultPositions
The AnalysisResultPositions class contains information about analysis result positions.
Public classAnalysisRigidDiaphragm
The AnalysisRigidDiaphragm class contains information related to analysis rigid diaphragms.
Public classAnalysisSubSection
The AnalysisSubSection class contains information related to analysis subsections.
Public classAnalysisSupport
The AnalysisSupport class contains information related to analysis supports.
Public classAnalysisVolume
The AnalysisVolume class contains information related to analysis volumes.
Public classAnalysisVolumeItem
The AnalysisVolumeItem class contains information related to analysis volume items.
Structures
  StructureDescription
Public structureDotAnalysisModelObjectOperation
The serialization structure for analysis model object operations.
Enumerations
  EnumerationDescription
Public enumerationAnalysisBarCardinalPointEnum
The cardinal point types of the analysis bar.
Public enumerationAnalysisConnectivityCombinedTypeEnum
The combined types.
Public enumerationAnalysisConnectivityConnectivityEnum
The connectivity types.
Public enumerationAnalysisDecomposedLoadAnalysisDecomposedLoadDirectionEnum
Defines the analysis decomposed load directions.
Public enumerationAnalysisDecomposedLoadAnalysisLoadTypeEnum
Defines the analysis load types.
Public enumerationAnalysisDecomposedLoadLoadCoordinateEnum
This defines whether local or global coordinates are used for loading the coordinate system.
Public enumerationAnalysisDesignParameterMultiDesignParIndex
Multi value design parameter indexes
Public enumerationAnalysisLoadCombinationLoadCombinationEnum
The load combination types.
Public enumerationAnalysisLoadGroupLoadGroupDirectionEnum
The directions of a load group.
Public enumerationAnalysisLoadGroupLoadGroupTypeEnum
The types of load groups.
Public enumerationAnalysisMaterialMaterialTypeEnum
The material types.
Public enumerationAnalysisModelAnalysisMethodEnum
The analysis methods.
Public enumerationAnalysisModelAxisLocationEnum
The axis location.
Public enumerationAnalysisModelConstructionMethodEnum
The construction methods.
Public enumerationAnalysisModelKeepAxisEnum
The keep axis settings.
Public enumerationAnalysisModelAnalysisPropertiesAnalysisMethodEnum
Defines the analysis method.
Public enumerationAnalysisModelDesignPropertiesDesignMethodEnum
The design methods.
Public enumerationAnalysisModelGeneralPropertiesMemberAxisLocationEnum
Defines the member axis location.
Public enumerationAnalysisModelGeneralPropertiesModelCreationTypeEnum
Defines the model creation type.
Public enumerationAnalysisModelIssueSeverityEnum
Issue severity.
Public enumerationAnalysisModelIssueTypeEnum
Issue type.
Public enumerationAnalysisObjectAnalysisObjectEnum
All subclasses of analysis objects are defined here. This enumeration can be used to select certain types of analysis objects.
Public enumerationAnalysisObjectEnumeratorAnalysisEnumeratorTypeEnum
The available enumerator types.
Public enumerationAnalysisPartAnalysisTypeEnum
The analysis types.
Public enumerationAnalysisPartItemTypeEnum
The item types.
Public enumerationAnalysisPartPartTypeEnum
The types of the physical model part.
Public enumerationAnalysisPartAnalysisPropertiesAnalysisClassEnum
The analysis classes.
Public enumerationAnalysisPartAnalysisPropertiesBuiltupEnum
The builtup settings.
Public enumerationAnalysisPartAreaAttributesAreaElementTypeEnum
The area element types.
Public enumerationAnalysisPartAreaAttributesAreaSupportEnum Obsolete.
The area support options.
Public enumerationAnalysisPartAreaAttributesAreaSupportTypeEnum
The new area support options.
Public enumerationAnalysisPartBarAttributesForceStraightSegmentsEnum
The straight force segments.
Public enumerationAnalysisPartCompositePropertiesCompositeBeamEnum
The composite beam options.
Public enumerationAnalysisPartCompositePropertiesCompositeBeamWidthEnum
The composite beam width options.
Public enumerationAnalysisPartEndConditionEnum
The conditions of the part end.
Public enumerationAnalysisPartEndEccentricityModeEnum
The eccentricity modes of the part end.
Public enumerationAnalysisPartPositionPropertiesAxisLocationEnum
The axis location.
Public enumerationAnalysisPartPositionPropertiesAxisModifierEnum
The axis modifiers.
Public enumerationAnalysisPartPositionPropertiesLongitudinalOffsetEnum
The longitudinal offsets.
Public enumerationAnalysisPartSpanningPropertiesSpanningTypeEnum
The spanning types.
Public enumerationAnalysisPositionTypeEnum
The position types.
Public enumerationAnalysisRestraintDataReleaseTypeEnum
Defines the release type.
Public enumerationAnalysisRestraintDataRestraintTypeEnum
Defines all the restraint types.
Public enumerationAnalysisRestraintDataSupportedEnum
Defines how the part is supported.
Public enumerationCode exampleAnalysisResultLoadCaseForMinMaxEnum
Special load case numbers for min/max queries.
Public enumerationAnalysisResultLoadCaseTypeEnum
The load case type.
Public enumerationAnalysisResultObjectTypeEnum
The object type.
Public enumerationAnalysisResultResultPositionEnum
The result position.
Public enumerationAnalysisResultValueTypeEnum
The value type.
Public enumerationAnalysisSubSectionAnalysisSubSectionSubTypeEnum
Defines the subsection subtypes.
Public enumerationAnalysisSubSectionAnalysisSubSectionTypeEnum
Defines the subsection types.
Public enumerationAnalysisSupportSupportEnum
The connectivity types.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next