Tekla.Structures Namespace |
The Tekla.Structures namespace contains some basic common types that are shared between Tekla Structures Model and Drawing.
Classes
Class | Description | |
---|---|---|
Assertion |
Defines an assertion by the method it failed in and the messages it
provided.
| |
ClashCheckOptions | The ClashCheckOptions class represents the clash check options. | |
ComponentOptions | The ComponentOptions class represents the component options. | |
Identifier |
The Identifier class represents an identifier that holds information
about the identifier number of an object.
| |
ModuleManager |
The ModuleManager class handles the product model module configuration information: the
information that defines what configuration the customer is currently running.
| |
TeklaStructuresFiles |
The TeklaStructuresFiles class is for the paths where the attributes file will be searched for.
| |
TeklaStructuresInfo | The TeklaStructuresInfo class provides information about Tekla Structures. | |
TeklaStructuresSettings |
The TeklaStructuresSettings class provides methods to inquire application settings.
| |
TeklaStructuresSettingsToolOptionNames |
Tool option names.
| |
TeklaStructuresVariables |
The EnvironmentVariables class contains a sorted list specializing in getting active
environment variables and advanced option settings. It also checks options.ini files
in the active model folder as well as options_user.ini files.
|
Delegates
Delegate | Description | |
---|---|---|
TeklaStructuresSettingsInvalidPathCallback |
The invalid path callback - provides error logging for GetAdvancedOptionPaths when a string is found to be invalid as a path
|
Enumerations
Enumeration | Description | |
---|---|---|
AutoDirectionTypeEnum |
The auto direction type defines how a connection or detail coordinate system will be oriented automatically.
| |
ComponentDefinitionTypeEnum |
The component definition type tells what kind of a component is in question.
| |
ComponentOptionsBoltEdgeDistanceReferenceEnum | The bolt edge distance reference type. | |
ConnectionStatusEnum |
The status type defines what the status of a connection or a detail is.
In the model the color of the symbol (green, yellow, red) indicates the status.
| |
DetailTypeEnum |
The detail type defines what kind of a detail is in question.
| |
ModuleManagerProgramConfigurationEnum | The configuration information of the program. | |
PositionTypeEnum |
The position type for connections and details.
| |
PropertyTypeEnum | The type of property: int/double/string. | |
TeklaStructuresDatabaseTypeEnum | The object types to be used in filter expressions. |