TeklaProgressBar Class |
The TeklaProgressBar class represents the common progress bar control for the Open API.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogTeklaProgressBar
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogTeklaProgressBar
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The TeklaProgressBar type exposes the following members.
Constructors
Name | Description | |
---|---|---|
TeklaProgressBar | Initializes the common progress bar control. |
Properties
Name | Description | |
---|---|---|
Text | Gets or sets the current message text of the progress bar. | |
Value | Gets or sets the current position of the progress bar. |
Events
Name | Description | |
---|---|---|
CancelClicked | The CancelClicked event is raised when the cancel button is clicked. |
See Also