TaskDependency Constructor (Task, Task)

Creates a new task dependency instance with the given primary and secondary tasks.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public TaskDependency(
	Task primary,
	Task secondary
)

Parameters

primary
Type: Tekla.Structures.ModelTask
The primary task to be used.
secondary
Type: Tekla.Structures.ModelTask
The secondary task to be used.
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           bool Result = false;
           Task Task1 = new Task();
           Task Task2 = new Task();
           Task1.Name = "Default Task 0000";
           Task2.Name = "Default Task 0001";
           Task1.Insert();
           Task2.Insert();
           TaskDependency TaskDependency1 = new TaskDependency(Task1, Task2);
           TaskDependency1.DependencyType = TaskDependency.DependencyTypeEnum.START_TO_FINISH;
           Result = TaskDependency1.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next