SymbolElement Class |
The SymbolElement class represents a symbol in the Tekla Structures symbol library.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The SymbolElement type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SymbolElement |
Creates a new symbol element instance with the default symbol.
| |
SymbolElement(SymbolInfo) |
Creates a new symbol element instance with the given symbol.
| |
SymbolElement(SymbolInfo, DrawingColors, Double) |
Creates a new symbol element instance with the given symbol, color and height.
|
Properties
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
(Overrides ElementBaseClone.) | |
GetUnformattedString |
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).) |
See Also