Symbol Constructor (ViewBase, Point, SymbolInfo, SymbolSymbolAttributes) |
Creates a new symbol instance using the given attributes.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public Symbol( ViewBase View, Point InsertionPoint, SymbolInfo SymbolInfo, SymbolSymbolAttributes Attributes )
Parameters
- View
- Type: Tekla.Structures.DrawingViewBase
The view where to insert the symbol. - InsertionPoint
- Type: Tekla.Structures.Geometry3dPoint
The location where to place the symbol. - SymbolInfo
- Type: Tekla.Structures.DrawingSymbolInfo
The symbol information to be used. - Attributes
- Type: Tekla.Structures.DrawingSymbolSymbolAttributes
The symbol attributes to be applied.
See Also