StructuresFieldAttribute Class |
The StructuresFieldAttribute class is used for mapping a database attribute to a data field that the plug-in uses in execution.
The attribute is initialized from the custom attribute [StructuresField(attributeName)] in the plug-in source.
In the plug-in the data field must be public and the type must be double, integer or string.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The StructuresFieldAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
StructuresFieldAttribute |
The custom attribute [StructuresField(attributeName)] uses this to map a database attribute to a data field that the plug-in uses in execution.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
AttributeName |
The name of the attribute.
|
See Also