StructuresDialogAttribute Class |
The StructuresDialogAttribute class specifies the attribute name to which the value of the
property will be bound in Tekla Structures.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The StructuresDialogAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
StructuresDialogAttribute(String) |
Initializes a new StructuresDialogAttribute instance.
| |
StructuresDialogAttribute(String, String) |
Initializes a new StructuresDialogAttribute instance.
| |
StructuresDialogAttribute(String, Type) |
Initializes a new StructuresDialogAttribute instance.
|
Properties
Name | Description | |
---|---|---|
AttributeName |
Gets the attribute name of the property.
| |
AttributeType |
Gets the attribute type of the property.
|
Methods
Name | Description | |
---|---|---|
GetCorrectDialogAttributeType |
Initializes a new StructuresDialogAttribute instance.
| |
ToString |
Returns a string that represents the current StructuresDialogAttribute object.
(Overrides ObjectToString.) |
See Also