DistanceListToString Method (IFormatProvider) |
Returns the string representation of the distance list.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
Parameters
- formatProvider
- Type: SystemIFormatProvider
The format provider.
Return Value
Type: StringThe string representation of the distance list.
Examples
This example shows how to override the format provider
when formatting a DistanceList instance.
The Tekla Structures convention is to use a dot as the decimal separator in all locales.
using Tekla.Structures.Datatype; using System.Globalization; public class Example { public void Example1() { // Current unit type controls the default unit type used in formatting. // The default unit is millimeter. Distance.CurrentUnitType = Distance.UnitType.Millimeter; // UseFractionalFormat controls whether the feet and inches are formatted // using the fractional representation. The default value is false which // causes the feet and inches to be represented as decimal numbers. Distance.UseFractionalFormat = false; // UseUnitsInDecimalString controls whether the unit type is shown in the // decimal string representation. The default is false. Distance.UseUnitsInDecimalString = false; // We'll use this distance list to demonstrate the formatting. DistanceList distanceList = new DistanceList(new Distance[] { new Distance(30.2), new Distance(30.2), new Distance(30.2), new Distance(50), new Distance(2.3), new Distance(2.3), }); // Tekla Structures uses dot as the decimal separator in all locales. string TeklaStructuresFormat = distanceList.ToString(null, CultureInfo.InvariantCulture); } }
See Also