DistanceToString Method (IFormatProvider) |
Creates a string representation of the distance.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
Parameters
- formatProvider
- Type: SystemIFormatProvider
The number format provider.
Return Value
Type: StringThe string representation of the distance.
Examples
This example shows how to specify a format provider when converting a
Distance instance to a string.
using Tekla.Structures.Datatype; using System.Globalization; public class Example { public void Example1() { // For this demonstration, we'll format 300.2 millimeters. Distance distance = new Distance(300.2); // Tekla Structures uses dot as the decimal separator in all locales. string formattedString = distance.ToString(CultureInfo.InvariantCulture); } }
See Also