![]() | StringList Class |
The StringList class defines a type safe string collection.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3

The StringList type exposes the following members.

Name | Description | |
---|---|---|
![]() | StringList |
Creates a new string list instance.
|
![]() | StringList(Int32) |
Creates a new string list instance with the given capacity.
|


Name | Description | |
---|---|---|
![]() | Add |
Adds a new string to the end of the string list.
|
![]() | Contains |
Checks if the string is in the list.
|
![]() | GetRange |
Gets a part of the string list.
|
![]() | IndexOf(String) |
Gets the index of the specified string.
|
![]() | IndexOf(String, Int32) |
Gets the index of the specified string between the index to start
the search from and the end of the list.
|
![]() | IndexOf(String, Int32, Int32) |
Gets the index of the specified string between the index to start the search from and startIndex + count.
|
![]() | Insert |
Inserts the string to the specified index.
|
![]() | IsEqual |
Compares the current object with an object of the same type.
|
![]() | LastIndexOf(String) |
Searches for the last occurence of the string in the list.
|
![]() | LastIndexOf(String, Int32) |
Searches for the last occurence of the string in the list.
|
![]() | LastIndexOf(String, Int32, Int32) |
Searches for the last occurence of the string in the list.
|
![]() | Remove |
Removes the first occurence of the string from the list.
|
![]() | RemoveRange |
Removes a range of items starting from the given index.
|
![]() | ToArray |
Copies the strings to a string array.
|

using Tekla.Structures.Drawing; public class Example { public void Example1() { StringList stringList = new StringList(); stringList.Add("MyString"); stringList.Add("MySecondString"); } }