StraightDimensionSetStraightDimensionSetAttributes Class |
The StraightDimensionSetAttributes class contains the attributes for managing
all the attributes of the straight dimension.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The StraightDimensionSetStraightDimensionSetAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
StraightDimensionSetStraightDimensionSetAttributes | Obsolete.
Creates a default straight dimension set attributes instance that loads standard attributes.
| |
StraightDimensionSetStraightDimensionSetAttributes(String) | Obsolete.
Creates a straight dimension set attributes instance that loads the specified attributes.
| |
StraightDimensionSetStraightDimensionSetAttributes(ModelObject) |
Creates a default straight dimension set attributes instance that loads standard attributes.
| |
StraightDimensionSetStraightDimensionSetAttributes(ModelObject, String) |
Creates a straight dimension set attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) | |
CombinedDimension |
Combines the attributes of the dimension.
| |
DimensionType |
The dimension type.
| |
Exaggeration |
The exaggeration attributes of the dimension.
| |
ExcludePartsAccordingToFilter |
Sets the filter to use for excluding parts from the tags.
You may query the possible filters using StraightDimensionSet.GetAllExcludePartsAccordingToFilter()
| |
ExtensionLine |
The extension line presentation of the dimension.
| |
Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
IncludePartCountInTag |
Gets or sets whether the part count is included in at least one of the tag position, or set part count flag for all tag positions.
| |
IncludePartCountInTagA |
Gets or sets a value indicating whether the part count is included in the tag A.
| |
IncludePartCountInTagB |
Gets or sets a value indicating whether the part count is included in the tag B.
| |
IncludePartCountInTagC |
Gets or sets a value indicating whether the part count is included in the tag C.
| |
IncludePartCountInTagD |
Gets or sets a value indicating whether the part count is included in the tag D.
| |
IncludePartCountInTagE |
Gets or sets a value indicating whether the part count is included in the tag E.
| |
IncludePartCountInTagF |
Gets or sets a value indicating whether the part count is included in the tag F.
| |
IncludePartCountInTagG |
Gets or sets a value indicating whether the part count is included in the tag G.
| |
LeftLowerTag |
The left lower dimension tag.
| |
LeftMiddleTag |
The left middle dimension tag.
| |
LeftUpperTag |
The left upper dimension tag.
| |
Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
RightLowerTag |
The right lower dimension tag.
| |
RightMiddleTag |
The right middle dimension tag.
| |
RightUpperTag |
The right upper dimension tag.
| |
ShortDimension |
How short dimensions are shown.
| |
Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
Examples
using Tekla.Structures.Drawing; public class Example { public void Example1() { StraightDimensionSet.StraightDimensionSetAttributes attributes = new StraightDimensionSet.StraightDimensionSetAttributes(null, "MyAttributes"); } }
See Also