Storey Class |
Class for Building Hierarchy Storey
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelInternal.BuildingHierarchyBuildingHierarchyItem
Tekla.Structures.ModelInternal.BuildingHierarchyStorey
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelInternal.BuildingHierarchyBuildingHierarchyItem
Tekla.Structures.ModelInternal.BuildingHierarchyStorey
Namespace: Tekla.Structures.ModelInternal.BuildingHierarchy
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The Storey type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
BottomOffset |
Gets or sets the Bottom offset of the storey.
| |
Description |
Gets or sets the Description of the storey.
| |
Elevation |
Gets or sets the Elevation of the storey.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
LevelInfo |
Gets or sets the Information of the storey.
| |
LevelOffset |
Gets or sets the Level Offset of the storey.
| |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
Gets or sets the Name of the hierarchic object.
(Inherited from BuildingHierarchyItem.) | |
Parent |
Gets or sets the parent building of the storey.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the Building Hierarchy object instance with the given identifier from the model database.
TODO: TTSD-37779 Delete won't work with TeklaModel implementation because dotPluginInterface_ci::DeleteObject fails to find id.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetGuid |
Gets Guid of Building Hierarchy object.
(Inherited from BuildingHierarchyItem.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetManualObjectOverrides |
Gets all manually overridden objects from this Building Hierarchy item.
| |
GetObjects |
Gets all ModelObjects that belong to this Storey. The objects still need to be selected separately after calling this method.
| |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetSpaces |
Gets all spaces belonging to this storey.
| |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts this Building Hierarchy object into model database. All the attributes must be set.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing Building Hierarchy object in the model database to match the current one.
(Overrides ModelObjectModify.) | |
RemoveManualObjectOverrides |
Removes specified manual overrides from this Building Hierarchy item.
| |
Select |
Selects the Building Hierarchy object from model database. The object identifier must be set.
(Overrides ModelObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetGuid |
Sets Guid for Building Hierarchy object. To be used when selecting object.
(Inherited from BuildingHierarchyItem.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetManualObjectOverrides |
Manually overrides grouping rules and directly assigns specified model objects to a Building Hierarchy object.
| |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
See Also