OperationSplitSlab Method |
This command is meant for specifically splitting a concrete slab with
advanced solid operations to create more robust and user friendly results
than the command:
public static ContourPlate Split(ContourPlate Object, Polygon SplitPolygon).
No validation is done for the type, it is the caller's responsibility to call
this only for valid types (slabs). Behavior for non-slabs is undetermined.
Namespace: Tekla.Structures.Model.Operations
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Parameters
- PartId
- Type: SystemInt32
The part ID that identifies the slab to be split - Polymesh
- Type: Tekla.Structures.Geometry3dFacetedBrep
The polymesh that defines the splitting surface
Return Value
Type: BooleanTrue on success.
See Also