BentPlateGeometrySolverSplit Method

Returns the resulting geometry or geometries when a section and the related automatically created sections are removed from this geometry.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public IList<ConnectiveGeometry> Split(
	ConnectiveGeometry geometry,
	GeometrySection geometrySection
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
ConnectiveGeometry used for split operation.
geometrySection
Type: Tekla.Structures.ModelGeometrySection
GeometrySection to remove.

Return Value

Type: IListConnectiveGeometry
The resulting geometries once the section and related automatic sections are removed.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when the supplied geometrySection is invalid or geometry is a stand-alone bend geometry, meaning that the first GeometrySection is a BendSurfaceNode.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next