SpiralBeamErrorStatus Enumeration |
Define possible statuses for geometry creation/modification commands.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
DataMissing | 0 | Status when some part data is missing. | |
DefinitionPointsTooClose | 1 | Status when definition points are too close. | |
DefinitionPointsCannotBeAligned | 2 | Status when definition points are on line with sweep direction. | |
ZeroTotalRiseWithMore360Degrees | 3 | Status when total rise is zero and rotation angle more than 360 degrees. | |
RotationAngleIs0Degrees | 4 | Status when rotation angle is 0 degrees. | |
InvalidGeometry | 5 | Status when helix has invalid geometry. |
See Also