SpiralBeam Constructor (Point, Point, Point, Double, Double) |
Initializes a new instance of the SpiralBeam class with the given parameters.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public SpiralBeam( Point startPoint, Point rotationAxisBasePoint, Point rotationAxisUpPoint, double totalRise, double rotationAngle )
Parameters
- startPoint
- Type: Tekla.Structures.Geometry3dPoint
The spiral beam starting point. - rotationAxisBasePoint
- Type: Tekla.Structures.Geometry3dPoint
The first definition point of the spiral beam rotation axis. - rotationAxisUpPoint
- Type: Tekla.Structures.Geometry3dPoint
The second definition point of the spiral beam rotation axis. - totalRise
- Type: SystemDouble
The difference between the spiral beam start and end point along the rotation axis direction. - rotationAngle
- Type: SystemDouble
The spiral beam cumulative rotation angle.
See Also