SpiralBeam Constructor (Point, Point, Double, Double)

Initializes a new instance of the SpiralBeam class with the given parameters. Rotation axis direction is current positive Z direction.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public SpiralBeam(
	Point startPoint,
	Point rotationAxisPoint,
	double totalRise,
	double rotationAngle
)

Parameters

startPoint
Type: Tekla.Structures.Geometry3dPoint
The spiral beam starting point.
rotationAxisPoint
Type: Tekla.Structures.Geometry3dPoint
A point on the spiral beam rotation axis.
totalRise
Type: SystemDouble
The difference between the spiral beam start and end point along the rotation axis direction.
rotationAngle
Type: SystemDouble
The spiral beam cumulative rotation angle.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next